sunxi: respect CONFIG_TARGET_IMAGES_GZIP
authorJohn Crispin <blogic@openwrt.org>
Tue, 1 Mar 2016 08:14:38 +0000 (08:14 +0000)
committerJohn Crispin <blogic@openwrt.org>
Tue, 1 Mar 2016 08:14:38 +0000 (08:14 +0000)
Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Backport of r46608

git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@48836 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/sunxi/image/Makefile

index 19ab935..d3f4409 100644 (file)
@@ -43,6 +43,10 @@ define Image/Build/SDCard
                $(CONFIG_SUNXI_SD_BOOT_PARTSIZE) \
                $(CONFIG_TARGET_ROOTFS_PARTSIZE) \
                $(KDIR)/uboot-sunxi-$(PROFILE)-u-boot-with-spl.bin
+
+  ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
+       gzip -f9n $(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE)-sdcard-vfat-$(1).img
+  endif
 endef
 
 define Image/Build/Profile/A10-OLinuXino-Lime