[packages] pyserial: fix build
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 13 Oct 2011 11:11:08 +0000 (11:11 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 13 Oct 2011 11:11:08 +0000 (11:11 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@28431 3c298f89-4303-0410-b956-a3cf2f4a3e73

lang/pyserial/Makefile

index dceb461..aed6919 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -34,14 +34,16 @@ define Package/pyserial/description
 endef
 
 define Build/Compile
-       $(call Build/Compile/PyMod,,install --prefix="$(PKG_INSTALL_DIR)/usr")
+       $(call Build/Compile/PyMod,., \
+               install --prefix="/usr" --root="$(PKG_INSTALL_DIR)", \
+       )
 endef
 
 define Package/pyserial/install
        $(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
        $(CP) \
            $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
-           $(1)$(PYTHON_PKG_DIR)
+           $(1)$(PYTHON_PKG_DIR)/
 endef
 
 $(eval $(call BuildPackage,pyserial))