[net] Web Servers/Proxies: Move all web servers, proxies, and related programs into...
authorcshore <cshore@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 12 Mar 2011 04:41:35 +0000 (04:41 +0000)
committercshore <cshore@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 12 Mar 2011 04:41:35 +0000 (04:41 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@26061 3c298f89-4303-0410-b956-a3cf2f4a3e73

20 files changed:
libs/axtls/Makefile
net/apache/Makefile
net/appweb/Makefile
net/crowdcontrol/Makefile
net/dansguardian/Makefile
net/dante/Makefile
net/haproxy/Makefile
net/hiawatha/Makefile
net/lighttpd/Makefile
net/mini_httpd/Makefile
net/nginx/Makefile
net/pepsal/Makefile
net/polipo/Makefile
net/spawn-fcgi/Makefile
net/squid/Makefile
net/srelay/Makefile
net/tinyproxy/Makefile
net/transocks/Makefile
net/tsocks/Makefile
net/wccpd/Makefile

index 7c428a7..d719a9b 100644 (file)
@@ -27,7 +27,7 @@ define Package/libaxtls
 endef
 
 define Package/axhttpd
-  SUBMENU:=Web
+  SUBMENU:=Web Servers/Proxies
   SECTION:=net
   CATEGORY:=Network
   TITLE:=A small embedded web server using the axTLS library
@@ -39,7 +39,7 @@ define Package/axtlswrap
   SUBMENU:=SSL
   SECTION:=net
   CATEGORY:=Network
-  SUBMENU:=Web
+  SUBMENU:=Web Servers/Proxies
   TITLE:=A simple TLS/SSL wrapper using the axTLS library
   URL:=http://sourceforge.net/projects/axtls
   DEPENDS:=+libaxtls
index 22607ef..999b85d 100644 (file)
@@ -26,7 +26,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/apache/Default
   SECTION:=net
   CATEGORY:=Network
-  SUBMENU:=Web
+  SUBMENU:=Web Servers/Proxies
   TITLE:=The Apache Web Server
   URL:=http://httpd.apache.org/
 endef
index b30fa8d..d52e7ae 100644 (file)
@@ -34,6 +34,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/appweb
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Web Servers/Proxies
   TITLE:=Appweb Web Server
   URL:=http://www.appwebserver.org/
   DEPENDS:=@!avr32 +libpthread
index 700ed1b..941f31e 100644 (file)
@@ -20,7 +20,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/crowdcontrol
   SECTION:=net
   CATEGORY:=Network
-  SUBMENU:=Proxy Servers
+  SUBMENU:=Web Servers/Proxies
   TITLE:=The extra-light http proxy server
   URL:=http://sourceforge.net/projects/crowdcontrol/
 endef
index db6da36..59aadec 100644 (file)
@@ -23,7 +23,7 @@ define Package/dansguardian
   SECTION:=net
   DEPENDS:=+libpthread +uclibcxx +zlib
   CATEGORY:=Network
-  SUBMENU:=Proxy Servers
+  SUBMENU:=Web Servers/Proxies
   TITLE:=DansGuardian
   URL:=http://dansguardian.org
 endef
index ca4fe03..4e67ae3 100644 (file)
@@ -30,7 +30,6 @@ endef
 
 define Package/dante/default
   TITLE:=Dante SOCKS
-  SUBMENU:=Proxy Servers
   URL:=http://www.inet.no/dante/
 endef
 
@@ -62,6 +61,7 @@ endef
 
 define Package/sockd
   $(call Package/dante/default)
+  SUBMENU:=Web Servers/Proxies
   SECTION:=net
   CATEGORY:=Network
   TITLE+= Daemon
@@ -82,6 +82,7 @@ define Package/socksify
   $(call Package/dante/default)
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Web Servers/Proxies
   TITLE+= Client
 endef
 
index f0d90e5..88a3c97 100644 (file)
@@ -19,7 +19,7 @@ PKG_MD5SUM:=9cc607f914215b5a781a17f8524ffb6a
 include $(INCLUDE_DIR)/package.mk
 
 define Package/haproxy
-  SUBMENU:=Proxy Servers
+  SUBMENU:=Web Servers/Proxies
   SECTION:=net
   CATEGORY:=Network
   TITLE:=The Reliable, High Performance TCP/HTTP Load Balancer
index 7b3bfdb..adc48f3 100644 (file)
@@ -22,7 +22,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/hiawatha
   CATEGORY:=Network
   SECTION:=net
-  SUBMENU:=Web
+  SUBMENU:=Web Servers/Proxies
   TITLE:=A very lightweight web server
   URL:=http://www.hiawatha-webserver.org/
   MAINTAINER:=RaphaĆ«l HUCK <rhk@cksum.org>
index 0eebabc..e2d5598 100644 (file)
@@ -21,7 +21,7 @@ PKG_INSTALL:=1
 include $(INCLUDE_DIR)/package.mk
 
 define Package/lighttpd/Default
-  SUBMENU:=Web
+  SUBMENU:=Web Servers/Proxies
   SECTION:=net
   CATEGORY:=Network
   URL:=http://www.lighttpd.net/
index e597649..669d9b7 100644 (file)
@@ -20,7 +20,7 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/mini_httpd-$(PKG_VERSION)
 include $(INCLUDE_DIR)/package.mk
 
 define Package/mini-httpd/Default
-  SUBMENU:=Web
+  SUBMENU:=Web Servers/Proxies
   SECTION:=net
   CATEGORY:=Network
   TITLE:=A small web server
index 2c4a552..26d862c 100644 (file)
@@ -29,6 +29,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/nginx
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Web Servers/Proxies
   TITLE:=Nginx web server
   URL:=http://nginx.net/
   DEPENDS:=+libpcre +NGINX_SSL:libopenssl +zlib
index 0814272..6c68e20 100644 (file)
@@ -23,7 +23,7 @@ define Package/pepsal
   TITLE:=Performance Enhancing Proxy
   SECTION:=net
   CATEGORY:=Network
-  SUBMENU:=Proxy Servers
+  SUBMENU:=Web Servers/Proxies
   URL:=http://pepsal.sourceforge.net/
   DEPENDS:=+libnetfilter-queue
 endef
index 5fd6047..bbd54eb 100644 (file)
@@ -18,7 +18,7 @@ PKG_MD5SUM:=bfc5c85289519658280e093a270d6703
 include $(INCLUDE_DIR)/package.mk
 
 define Package/polipo
-  SUBMENU:=Proxy Servers
+  SUBMENU:=Web Servers/Proxies
   SECTION:=net
   CATEGORY:=Network
   TITLE:=A caching web proxy
index 55170a0..560f3be 100644 (file)
@@ -20,7 +20,7 @@ PKG_INSTALL = 1
 include $(INCLUDE_DIR)/package.mk
 
 define Package/spawn-fcgi
-  SUBMENU:=Web
+  SUBMENU:=Web Servers/Proxies
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Tool to spawn fastcgi applications
index 13994af..7ee3d79 100644 (file)
@@ -20,7 +20,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/squid/Default
   SECTION:=net
   CATEGORY:=Network
-  SUBMENU:=Proxy Servers
+  SUBMENU:=Web Servers/Proxies
   URL:=http://www.squid-cache.org/
 endef
 
index e1d86b8..7a8cb42 100644 (file)
@@ -21,7 +21,7 @@ define Package/srelay
   SECTION:=net
   CATEGORY:=Network
   DEPENDS:=+libwrap
-  SUBMENU:=Proxy Servers
+  SUBMENU:=Web Servers/Proxies
   TITLE:=A socks 4/5 proxy server
   URL:=http://www.c-wind.com/srelay/
 endef
index e12b43a..f219a09 100644 (file)
@@ -20,7 +20,7 @@ PKG_INSTALL:=1
 include $(INCLUDE_DIR)/package.mk
 
 define Package/tinyproxy
-  SUBMENU:=Proxy Servers
+  SUBMENU:=Web Servers/Proxies
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Tinyproxy is a lightweight HTTP and HTTPS proxy
index 998725d..bdcc1c9 100644 (file)
@@ -33,7 +33,7 @@ endef
 define Package/transocks
   SECTION:=net
   CATEGORY:=Network
-  SUBMENU:=Proxy Servers
+  SUBMENU:=Web Servers/Proxies
   TITLE:=Transparent SOCKSifying proxy
   DEPENDS:=+libsocks $(LIBRPC_DEPENDS)
 endef
index 79eaa12..305fc36 100644 (file)
@@ -23,7 +23,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/tsocks
   SECTION:=net
   CATEGORY:=Network
-  SUBMENU:=Proxy Servers
+  SUBMENU:=Web Servers/Proxies
   TITLE:=Transparent SOCKS v4 proxying library
   URL:=http://tsocks.sourceforge.net/
 endef
index 675034c..67b0153 100644 (file)
@@ -22,7 +22,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/wccpd
   SECTION:=net
   CATEGORY:=Network
-  SUBMENU:=Proxy Servers
+  SUBMENU:=Web Servers/Proxies
   TITLE:=a Web Cache Coordination daemon
   URL:=http://wccpd.sourceforge.net/
 endef