[packages] collectd: fix build failure on avr32
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 16 Jul 2010 12:12:02 +0000 (12:12 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 16 Jul 2010 12:12:02 +0000 (12:12 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@22232 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/collectd/Makefile

index a7047e2..763a600 100644 (file)
@@ -135,6 +135,10 @@ define Package/collectd/description
  and provides mechanismns to store the values in a variety of ways.
 endef
 
+ifneq ($(CONFIG_avr32),)
+  TARGET_CFLAGS += -fsigned-char
+endif
+
 # common configure args
 CONFIGURE_ARGS+= \
        --disable-debug \