[packages] net/nagios-plugins: Add dependency on libpq (postgresql) and fix headers
authoragb <agb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 2 Aug 2008 03:19:51 +0000 (03:19 +0000)
committeragb <agb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 2 Aug 2008 03:19:51 +0000 (03:19 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@12070 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/nagios-plugins/Makefile
net/nagios-plugins/patches/003-pgsl-header-fix.patch [new file with mode: 0644]

index 1c919bf..5ef65c7 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -24,7 +24,7 @@ define Package/nagios-plugins
   SECTION:=net
   CATEGORY:=Network
   SUBMENU:=Monitoring
-  DEPENDS:=+uclibcxx
+  DEPENDS:=+uclibcxx +libpq
   TITLE:=plugins for Nagios checks
   URL:=http://nagiosplug.sourceforge.net/
 endef
diff --git a/net/nagios-plugins/patches/003-pgsl-header-fix.patch b/net/nagios-plugins/patches/003-pgsl-header-fix.patch
new file mode 100644 (file)
index 0000000..8129754
--- /dev/null
@@ -0,0 +1,11 @@
+--- nagios-plugins-1.4.12/plugins/check_pgsql.orig.c   2008-08-01 16:05:51.000000000 -0700
++++ nagios-plugins-1.4.12/plugins/check_pgsql.c        2008-08-01 16:06:17.000000000 -0700
+@@ -41,7 +41,7 @@
+ #include "netutils.h"
+ #include <libpq-fe.h>
+-#include <pg_config_manual.h>
++#include <postgresql/server/pg_config_manual.h>
+ #define NAMEDATALEN 64
+ #define DEFAULT_DB "template1"