packages: ntfsprogs_ntfs-3g: add missing dependency - libuuid
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 4 Aug 2013 12:03:14 +0000 (12:03 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 4 Aug 2013 12:03:14 +0000 (12:03 +0000)
This patch adds missing libuuid dependency for ntfsprogs_ntfs-3g.
Without it the package fails to install because of missing
dependency to libuuid.

Signed-off-by: Jiri Slachta <slachta@cesnet.cz>
[jogo@openwrt.org: also enable libuuid explicitly in configure]
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@37676 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/ntfs-3g/Makefile

index 4650344..30e7633 100644 (file)
@@ -126,12 +126,13 @@ endef
 define Package/ntfsprogs_ntfs-3g
   $(call Package/ntfs-3g/common)
   TITLE:=ntfsprogs (ntfs-3g)
-  DEPENDS+= +ntfs-3g +libgcrypt
+  DEPENDS+= +ntfs-3g +libgcrypt +libuuid
 endef
 
 CONFIGURE_ARGS += \
        --enable-shared \
-       --enable-static
+       --enable-static \
+       --with-uuid
 
 # configure/make according selection
 ifdef CONFIG_PACKAGE_NTFS-3G_USE_LIBFUSE