alsa-lib: moved to github
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 30 Jun 2014 13:32:24 +0000 (13:32 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 30 Jun 2014 13:32:24 +0000 (13:32 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@41419 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/alsa-lib/Makefile [deleted file]
libs/alsa-lib/patches/001-link_fix.patch [deleted file]
libs/alsa-lib/patches/002-ccache.patch [deleted file]

diff --git a/libs/alsa-lib/Makefile b/libs/alsa-lib/Makefile
deleted file mode 100644 (file)
index be2050e..0000000
+++ /dev/null
@@ -1,91 +0,0 @@
-#
-# Copyright (C) 2006-2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=alsa-lib
-PKG_VERSION:=1.0.27.2
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/lib/ \
-               http://alsa.cybermirror.org/lib/
-PKG_MD5SUM:=69129a7c37697f81ac092335e9fa452b
-
-PKG_LICENSE:=LGPLv2.1 GPLv2
-PKG_LICENSE_FILE:=COPYING aserver/COPYING
-
-PKG_FIXUP:=autoreconf
-PKG_INSTALL:=1
-PKG_USE_MIPS16:=0
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/alsa-lib
-  SECTION:=libs
-  CATEGORY:=Libraries
-  TITLE:=ALSA (Advanced Linux Sound Architecture) library
-  URL:=http://www.alsa-project.org/
-  DEPENDS:=@AUDIO_SUPPORT +kmod-sound-core +libpthread +librt
-endef
-
-define Package/alsa-lib/description
- This is the library package for alsa, needed by some userspace programs.
- You must have enabled the ALSA support in the kernel.
-endef
-
-TARGET_CFLAGS += $(FPIC)
-
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --disable-python \
-               --disable-debug \
-               --without-debug \
-               $(SOFT_FLOAT_CONFIG_OPTION) \
-               --with-versioned=no \
-       )
-endef
-
-define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include/
-       $(CP) \
-               $(PKG_INSTALL_DIR)/usr/include/alsa \
-               $(1)/usr/include/
-
-       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
-       $(CP) \
-               $(PKG_INSTALL_DIR)/usr/lib/libasound.{la,so*} \
-               $(1)/usr/lib/
-       $(INSTALL_DATA) \
-               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/alsa.pc \
-               $(1)/usr/lib/pkgconfig/
-
-       $(INSTALL_DIR) $(1)/usr/share/aclocal
-       $(INSTALL_DATA) \
-               $(PKG_INSTALL_DIR)/usr/share/aclocal/alsa.m4 \
-               $(1)/usr/share/aclocal/
-endef
-
-define Package/alsa-lib/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) \
-               $(PKG_INSTALL_DIR)/usr/lib/libasound.so.* \
-               $(1)/usr/lib/
-
-       $(INSTALL_DIR) $(1)/usr/share/alsa/{cards,pcm}
-       $(INSTALL_DATA) \
-               $(PKG_INSTALL_DIR)/usr/share/alsa/alsa.conf \
-               $(1)/usr/share/alsa/
-       $(INSTALL_DATA) \
-               $(PKG_INSTALL_DIR)/usr/share/alsa/pcm/* \
-               $(1)/usr/share/alsa/pcm/
-       $(CP) \
-               $(PKG_INSTALL_DIR)/usr/share/alsa/cards/* \
-               $(1)/usr/share/alsa/cards/
-endef
-
-$(eval $(call BuildPackage,alsa-lib))
diff --git a/libs/alsa-lib/patches/001-link_fix.patch b/libs/alsa-lib/patches/001-link_fix.patch
deleted file mode 100644 (file)
index 3f90edf..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/src/Makefile.in b/src/Makefile.in
-index e21fc0d..c8f3ea0 100644
---- a/src/Makefile.in
-+++ b/src/Makefile.in
-@@ -419,7 +419,7 @@ clean-libLTLIBRARIES:
-         rm -f $${locs}; \
-       }
- libasound.la: $(libasound_la_OBJECTS) $(libasound_la_DEPENDENCIES) $(EXTRA_libasound_la_DEPENDENCIES) 
--      $(AM_V_CCLD)$(libasound_la_LINK) -rpath $(libdir) $(libasound_la_OBJECTS) $(libasound_la_LIBADD) $(LIBS)
-+      $(AM_V_CCLD)$(libasound_la_LINK) -rpath $(DESTDIR)$(libdir) $(libasound_la_OBJECTS) $(libasound_la_LIBADD) $(LIBS)
- mostlyclean-compile:
-       -rm -f *.$(OBJEXT)
-diff --git a/src/pcm/scopes/Makefile.in b/src/pcm/scopes/Makefile.in
-index 469dbb5..391f3d4 100644
---- a/src/pcm/scopes/Makefile.in
-+++ b/src/pcm/scopes/Makefile.in
-@@ -348,7 +348,7 @@ clean-pkglibLTLIBRARIES:
-         rm -f $${locs}; \
-       }
- scope-level.la: $(scope_level_la_OBJECTS) $(scope_level_la_DEPENDENCIES) $(EXTRA_scope_level_la_DEPENDENCIES) 
--      $(AM_V_CCLD)$(scope_level_la_LINK) -rpath $(pkglibdir) $(scope_level_la_OBJECTS) $(scope_level_la_LIBADD) $(LIBS)
-+      $(AM_V_CCLD)$(scope_level_la_LINK) -rpath $(DESTDIR)$(pkglibdir) $(scope_level_la_OBJECTS) $(scope_level_la_LIBADD) $(LIBS)
- mostlyclean-compile:
-       -rm -f *.$(OBJEXT)
diff --git a/libs/alsa-lib/patches/002-ccache.patch b/libs/alsa-lib/patches/002-ccache.patch
deleted file mode 100644 (file)
index 45f9b36..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/configure.in b/configure.in
-index 00fff2b..af39300 100644
---- a/configure.in
-+++ b/configure.in
-@@ -24,22 +24,6 @@ m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
- AC_PREFIX_DEFAULT(/usr)
--dnl Checks for programs.
--
--dnl try to gues cross-compiler if not set
--if test "x$host" != "x$build" -a -z "`echo $CC | grep -e '-gcc'`";
--then
--  AC_MSG_CHECKING(for cross-compiler)
--
--  which ${program_prefix}gcc >/dev/null 2>&1 && CC=${program_prefix}gcc
--  which ${host_cpu}-${host_os}-gcc >/dev/null 2>&1 \
--  && CC=${host_cpu}-${host_os}-gcc
--  which ${host_cpu}-${host_vendor}-${host_os}-gcc >/dev/null 2>&1 \
--  && CC=${host_cpu}-${host_vendor}-${host_os}-gcc
--
--  AC_MSG_RESULT($CC)
--fi
--          
- CFLAGS="$CFLAGS -D_GNU_SOURCE"