[package] ffmpeg: expose additionnal configuration options (#7837, #8831)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 3 Apr 2011 18:29:39 +0000 (18:29 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 3 Apr 2011 18:29:39 +0000 (18:29 +0000)
This series, along with previous applied patches, should close tickets #7837 and #8831.

This patch exposes additional decoders and demuxers for FFmpeg in menuconfig, along with other minor changes.

Additional decoders:
flac (Free Lossless Audio Codec)

Additional demuxers:
aac
avi
flac
matroska
mov (mov/mp4/m4a/3gp/3g2/mj2)

zlib is required on matroska/mov to handle compressed headers.

Minor changes:
mp3 demuxer to require the mpegaudio parser. Doesn't do much without it. Matches current ffmpeg behavior.

--target-os=linux as a compile flag. This will be required when cross-compiling in the 0.6 branch, and does no harm here.

Signed-off-by: Ian Leonard <antonlacon_at_gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@26449 3c298f89-4303-0410-b956-a3cf2f4a3e73

multimedia/ffmpeg/Config.in
multimedia/ffmpeg/Makefile

index a2da1ff..326ef7c 100644 (file)
@@ -90,6 +90,9 @@ config FFMPEG_DECODER_atrac3
        bool "ATRAC3"
        depends FFMPEG_PATENTED
 
+config FFMPEG_DECODER_flac
+       bool "FLAC"
+
 config FFMPEG_DECODER_gif
        bool "GIF"
 
@@ -189,9 +192,18 @@ config FFMPEG_MUXER_rtp
 
 comment "Demuxers ---"
 
+config FFMPEG_DEMUXER_aac
+       bool "AAC"
+
+config FFMPEG_DEMUXER_avi
+       bool "AVI (Audio Video Interleave)"
+
 config FFMPEG_DEMUXER_ac3
        bool "AC3"
 
+config FFMPEG_DEMUXER_flac
+       bool "FLAC"
+
 config FFMPEG_DEMUXER_ffm
        bool "FFM (ffserver live feed)"
 
@@ -199,8 +211,17 @@ config FFMPEG_DEMUXER_h264
        bool "H.264"
        depends FFMPEG_PATENTED
 
+config FFMPEG_DEMUXER_matroska
+       bool "Matroska (MKA,MKV)"
+       select FFMPEG_DECODER_zlib
+
+config FFMPEG_DEMUXER_mov
+       bool "MOV/MP4/M4A/3GP/3G2/MJ2"
+       select FFMPEG_DECODER_zlib
+
 config FFMPEG_DEMUXER_mp3
        bool "MP3 (MPEG Audio Layer 3)"
+       select FFMPEG_PARSER_mpegaudio
 
 config FFMPEG_DEMUXER_mpegvideo
        bool "MPEG Video"
index 7677f13..101e7d9 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ffmpeg
 PKG_VERSION:=0.5.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://ffmpeg.org/releases/
@@ -31,6 +31,7 @@ FFMPEG_DECODERS:= \
        aac \
        ac3 \
        atrac3 \
+       flac \
        gif \
        h264 \
        jpegls \
@@ -63,9 +64,14 @@ FFMPEG_MUXERS:= \
        rtp \
 
 FFMPEG_DEMUXERS:= \
+       aac \
        ac3 \
+       avi \
+       flac \
        ffm \
        h264 \
+       matroska \
+       mov \
        mp3 \
        mpegps \
        mpegts \
@@ -81,8 +87,8 @@ FFMPEG_PARSERS:= \
        ac3 \
        h264 \
        mpegaudio \
-       mpegvideo \
        mpeg4video \
+       mpegvideo \
 
 FFMPEG_PROTOCOLS:= \
        file http pipe rtp tcp udp
@@ -200,6 +206,7 @@ define Build/Configure
                --enable-cross-compile \
                --cross-prefix="$(TARGET_CROSS)" \
                --arch="$(ARCH)" \
+               --target-os=linux \
                --prefix="/usr" \
                --enable-shared \
                --enable-static \