[packages/boost] level up, fix several issues
authormirko <mirko@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 15 Apr 2012 19:19:59 +0000 (19:19 +0000)
committermirko <mirko@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 15 Apr 2012 19:19:59 +0000 (19:19 +0000)
 - level up to version 1.49.0
 - package boost-chrono
 - package boost-locale
 - package boost-random
 - package boost-timer
 - add myself as maintainer
 - add dependencies among themselves
 - fix python include path (python2.6 -> python2.7)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@31297 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/boost/Makefile

index 7dfcd68..349fdc0 100644 (file)
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=boost
-PKG_VERSION:=1_48_0
+PKG_VERSION:=1_49_0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/boost
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_$(PKG_VERSION)
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)_$(PKG_VERSION)
-PKG_MD5SUM:=313a11e97eb56eb7efd18325354631be
+PKG_MD5SUM:=e0defc8c818e4f1c5bbb29d0292b76ca
 
 PKG_BUILD_DEPENDS:=boost/host
 PKG_BUILD_PARALLEL:=1
@@ -47,25 +47,44 @@ define Package/boost/Default
   TITLE:=Boost C++ source libraries
   URL:=http://www.boost.org
   DEPENDS:=+libstdcpp
+  MAINTAINER:=Mirko Vogt <mirko@openwrt.org>
 endef
 
 define Package/boost/Default/description
   Boost provides free peer-reviewed portable C++ source libraries
 endef
 
+define Package/boost-chrono
+  $(call Package/boost/Default)
+  TITLE+= (chrono)
+  DEPENDS+= +boost-system
+endef
+
 define Package/boost-date_time
   $(call Package/boost/Default)
   TITLE+= (date_time)
 endef
 
+define Package/boost-exception
+  $(call Package/boost/Default)
+  TITLE+= (exception)
+endef
+
 define Package/boost-filesystem
   $(call Package/boost/Default)
   TITLE+= (filesystem)
+  DEPENDS+= +boost-system
 endef
 
 define Package/boost-graph
   $(call Package/boost/Default)
   TITLE+= (graph)
+  DEPENDS+= +boost-regex
+endef
+
+define Package/boost-graph_parallel
+  $(call Package/boost/Default)
+  TITLE+= (graph_parallel)
 endef
 
 define Package/boost-iostreams
@@ -74,15 +93,20 @@ define Package/boost-iostreams
   DEPENDS+= +zlib
 endef
 
+define Package/boost-locale
+  $(call Package/boost/Default)
+  TITLE+= (locale)
+endef
+
 define Package/boost-math
   $(call Package/boost/Default)
   TITLE+= (math)
 endef
 
-#define Package/boost-mpi
-#  $(call Package/boost/Default)
-#  TITLE+= (mpi)
-#endef
+define Package/boost-mpi
+  $(call Package/boost/Default)
+  TITLE+= (mpi)
+endef
 
 define Package/boost-program_options
   $(call Package/boost/Default)
@@ -95,6 +119,11 @@ define Package/boost-python
   DEPENDS+= +python
 endef
 
+define Package/boost-random
+  $(call Package/boost/Default)
+  TITLE+= (random)
+endef
+
 define Package/boost-regex
   $(call Package/boost/Default)
   TITLE+= (regex)
@@ -125,9 +154,16 @@ define Package/boost-thread
   TITLE+= (thread)
 endef
 
+define Package/boost-timer
+  $(call Package/boost/Default)
+  TITLE+= (timer)
+  DEPENDS+= boost-chrono
+endef
+
 define Package/boost-wave
   $(call Package/boost/Default)
   TITLE+= (wave)
+  DEPENDS+= +boost-date_time +boost-thread +boost-filesystem
 endef
 
 define Package/boost
@@ -151,7 +187,7 @@ define Build/Compile
        ( cd $(PKG_BUILD_DIR) ; \
                echo "using gcc : : $(GNU_TARGET_NAME)-gcc : <compileflags>\"$(TARGET_CFLAGS)\" <cxxflags>\"$(TARGET_CXXFLAGS)\" <linkflags>\"$(TARGET_LDFLAGS)\" ;" > tools/build/v2/site-config.jam ; \
                $(if $(CONFIG_PACKAGE_boost-python), \
-                       echo "using python : : $(STAGING_DIR_ROOT)/usr/bin/python :     $(STAGING_DIR)/usr/include/python2.6/ ;" >> \
+                       echo "using python : : $(STAGING_DIR_ROOT)/usr/bin/python :     $(STAGING_DIR)/usr/include/python2.7/ ;" >> \
                                tools/build/v2/site-config.jam; \
                ) \
                bjam \
@@ -160,20 +196,26 @@ define Build/Compile
                        --toolset=gcc --build-type=minimal --layout=system \
                        --disable-long-double \
                        $(CONFIGURE_ARGS) \
+                       $(if $(CONFIG_PACKAGE_boost-chrono),,--without-chrono) \
                        $(if $(CONFIG_PACKAGE_boost-date_time),,--without-date_time) \
+                       $(if $(CONFIG_PACKAGE_boost-exception),,--without-exception) \
                        $(if $(CONFIG_PACKAGE_boost-filesystem),,--without-filesystem) \
                        $(if $(CONFIG_PACKAGE_boost-graph),,--without-graph) \
+                       $(if $(CONFIG_PACKAGE_boost-graph_parallel),,--without-graph_parallel) \
                        $(if $(CONFIG_PACKAGE_boost-iostreams),,--without-iostreams) \
+                       $(if $(CONFIG_PACKAGE_boost-locale),,--without-locale) \
                        $(if $(CONFIG_PACKAGE_boost-math),,--without-math) \
                        $(if $(CONFIG_PACKAGE_boost-mpi),,--without-mpi) \
                        $(if $(CONFIG_PACKAGE_boost-program_options),,--without-program_options) \
                        $(if $(CONFIG_PACKAGE_boost-python),,--without-python) \
+                       $(if $(CONFIG_PACKAGE_boost-random),,--without-random) \
                        $(if $(CONFIG_PACKAGE_boost-regex),,--without-regex) \
                        $(if $(CONFIG_PACKAGE_boost-serialization),,--without-serialization) \
                        $(if $(CONFIG_PACKAGE_boost-signals),,--without-signals) \
                        $(if $(CONFIG_PACKAGE_boost-system),,--without-system) \
                        $(if $(CONFIG_PACKAGE_boost-test),,--without-test) \
                        $(if $(CONFIG_PACKAGE_boost-thread),,--without-thread) \
+                       $(if $(CONFIG_PACKAGE_boost-timer),,--without-timer) \
                        $(if $(CONFIG_PACKAGE_boost-wave),,--without-wave) \
                        \
                        $(if $(CONFIG_PACKAGE_boost-iostreams),-sNO_BZIP2=1 -sZLIB_INCLUDE=$(STAGING_DIR)/usr/include \
@@ -183,30 +225,56 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include/boost/
-       $(CP) $(PKG_INSTALL_DIR)/include/boost/* $(1)/usr/include/boost/ # copies _all_ header files - independent of <--with-library>-argument above
+       $(INSTALL_DIR) \
+               $(1)/usr/include/boost/
+
+       $(CP) \
+               $(PKG_INSTALL_DIR)/include/boost/* \
+               $(1)/usr/include/boost/ \
+               # copies _all_ header files - independent of <--with-library>-argument above
 
        if [ -d $(PKG_INSTALL_DIR)/lib ]; then \
-               $(INSTALL_DIR) $(1)/usr/lib; \
-               $(CP) $(PKG_INSTALL_DIR)/lib/*.a $(1)/usr/lib/; \
-               $(CP) $(PKG_INSTALL_DIR)/lib/*.so* $(1)/usr/lib/; \
+               $(INSTALL_DIR) \
+                       $(1)/usr/lib; \
+               $(CP) \
+                       $(PKG_INSTALL_DIR)/lib/*.a \
+                       $(1)/usr/lib/; \
+               $(CP) \
+                       $(PKG_INSTALL_DIR)/lib/*.so* \
+                       $(1)/usr/lib/; \
        fi
 endef
 
 define Host/Install
-       $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin
-       $(CP) $(HOST_BUILD_DIR)/tools/build/v2/engine/bin.*/bjam $(STAGING_DIR_HOST)/bin/
+       $(INSTALL_DIR) \
+               $(STAGING_DIR_HOST)/bin
+
+       $(CP) \
+               $(HOST_BUILD_DIR)/tools/build/v2/engine/bin.*/bjam \
+               $(STAGING_DIR_HOST)/bin/
 endef
 
 define Package/boost/Default/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/lib/libboost_$(2)*.so* $(1)/usr/lib/
+       $(INSTALL_DIR) \
+               $(1)/usr/lib
+
+       $(CP) \
+               $(PKG_INSTALL_DIR)/lib/libboost_$(2)*.so* \
+               $(1)/usr/lib/
+endef
+
+define Package/boost-chrono/install
+  $(call Package/boost/Default/install,$(1),chrono)
 endef
 
 define Package/boost-date_time/install
   $(call Package/boost/Default/install,$(1),date_time)
 endef
 
+define Package/boost-exception/install
+  $(call Package/boost/Default/install,$(1),exception)
+endef
+
 define Package/boost-filesystem/install
   $(call Package/boost/Default/install,$(1),filesystem)
 endef
@@ -215,6 +283,10 @@ define Package/boost-graph/install
   $(call Package/boost/Default/install,$(1),graph)
 endef
 
+define Package/boost-graph_parallel/install
+  $(call Package/boost/Default/install,$(1),graph_parallel)
+endef
+
 define Package/boost-iostreams/install
   $(call Package/boost/Default/install,$(1),iostreams)
 endef
@@ -223,9 +295,9 @@ define Package/boost-math/install
   $(call Package/boost/Default/install,$(1),math)
 endef
 
-#define Package/boost-mpi/install
-#  $(call Package/boost/Default/install,$(1),mpi)
-#endef
+define Package/boost-mpi/install
+  $(call Package/boost/Default/install,$(1),mpi)
+endef
 
 define Package/boost-program_options/install
   $(call Package/boost/Default/install,$(1),program_options)
@@ -235,6 +307,10 @@ define Package/boost-python/install
   $(call Package/boost/Default/install,$(1),python)
 endef
 
+define Package/boost-random/install
+  $(call Package/boost/Default/install,$(1),random)
+endef
+
 define Package/boost-regex/install
   $(call Package/boost/Default/install,$(1),regex)
 endef
@@ -252,28 +328,44 @@ define Package/boost-system/install
 endef
 
 define Package/boost-test/install
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/lib/libboost_unit_test_framework*.so* $(1)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/lib/libboost_prg_exec_monitor*.so* $(1)/usr/lib/
+       $(INSTALL_DIR) \
+               $(1)/usr/lib
+
+       $(CP) \
+               $(PKG_INSTALL_DIR)/lib/libboost_unit_test_framework*.so* \
+               $(1)/usr/lib/
+
+       $(CP) \
+               $(PKG_INSTALL_DIR)/lib/libboost_prg_exec_monitor*.so* \
+               $(1)/usr/lib/
 endef
 
 define Package/boost-thread/install
   $(call Package/boost/Default/install,$(1),thread)
 endef
 
+define Package/boost-timer/install
+  $(call Package/boost/Default/install,$(1),timer)
+endef
+
 define Package/boost-wave/install
   $(call Package/boost/Default/install,$(1),wave)
 endef
 
 $(eval $(call HostBuild))
 $(eval $(call BuildPackage,boost))
+$(eval $(call BuildPackage,boost-chrono))
 $(eval $(call BuildPackage,boost-date_time))
+#$(eval $(call BuildPackage,boost-exception))
 $(eval $(call BuildPackage,boost-filesystem))
 $(eval $(call BuildPackage,boost-graph))
+#$(eval $(call BuildPackage,boost-graph_parallel))
 $(eval $(call BuildPackage,boost-iostreams))
+$(eval $(call BuildPackage,boost-locale))
 $(eval $(call BuildPackage,boost-math))
 #$(eval $(call BuildPackage,boost-mpi))
 $(eval $(call BuildPackage,boost-program_options))
+$(eval $(call BuildPackage,boost-random))
 $(eval $(call BuildPackage,boost-python))
 $(eval $(call BuildPackage,boost-regex))
 $(eval $(call BuildPackage,boost-serialization))
@@ -281,4 +373,5 @@ $(eval $(call BuildPackage,boost-signals))
 $(eval $(call BuildPackage,boost-system))
 $(eval $(call BuildPackage,boost-test))
 $(eval $(call BuildPackage,boost-thread))
+$(eval $(call BuildPackage,boost-timer))
 $(eval $(call BuildPackage,boost-wave))