[packages] privoxy: move privoxy startup to later in boot process
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 16 Jul 2012 22:53:46 +0000 (22:53 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 16 Jul 2012 22:53:46 +0000 (22:53 +0000)
When using privoxy as a transparent HTTP proxy a race condition occurs
where privoxy may attempt to startup and start listening on the LAN
interface before the network configuration is completed. As a result
privoxy fails to start up because it can't bind to the correct listening
address. This patch changes the init.d script to be a little bit later
in the boot process.

Signed-off-by: Adam Gensler <openwrt@kristenandadam.net>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@32759 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/privoxy/Makefile
net/privoxy/files/privoxy.init

index e4b45cf..8539ed7 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=privoxy
 PKG_VERSION:=3.0.19
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-stable-src.tar.gz
 PKG_SOURCE_URL:=@SF/ijbswa
index 0afe4c4..78c29b4 100644 (file)
@@ -1,8 +1,8 @@
 #!/bin/sh /etc/rc.common
 # Copyright (C) 2006-2011 OpenWrt.org
 
-START=50
-STOP=50
+START=80
+STOP=80
 
 SERVICE_USE_PID=1