Fix ip path checking and make 6scripts depend on kmod-ipv6 (#4085)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 11 Oct 2008 13:18:04 +0000 (13:18 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 11 Oct 2008 13:18:04 +0000 (13:18 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@12953 3c298f89-4303-0410-b956-a3cf2f4a3e73

ipv6/6scripts/Makefile
ipv6/6scripts/files/6tunnel.init

index 5600ff0..2b398d0 100644 (file)
@@ -17,6 +17,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/6scripts
   SECTION:=ipv6
   CATEGORY:=IPv6
+  DEPENDS:=+kmod-ipv6
   TITLE:=IPv6 scripts
 endef
 
index cd4e1fc..84ba325 100644 (file)
@@ -46,11 +46,7 @@ stop_service() {
        ip tunnel del $tnlifname
 }
 start() {
-       if ! [ -f /proc/net/if_inet6 ]; then
-               echo "IPv6 not enabled, install kmod-ipv6";
-               exit 1;
-       fi
-       if ! [ -x /sbin/ip ]; then
+       if ! [ -x /usr/sbin/ip ]; then
                echo "ip is required to setup the tunnel";
                exit 1;
        fi