[net] Routing and Redirection: Moved programs for routing and redirecting/relaying...
authorcshore <cshore@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 12 Mar 2011 06:55:07 +0000 (06:55 +0000)
committercshore <cshore@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 12 Mar 2011 06:55:07 +0000 (06:55 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@26072 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/babel/Makefile
net/batman/Makefile
net/bird/Makefile
net/bmxd/Makefile
net/net-tools/Makefile
net/redir/Makefile
net/rinetd/Makefile
net/smcroute/Makefile
net/udp-broadcast-relay/Makefile
net/vrrpd/Makefile
net/wing/Makefile

index 5f0e124..db654e9 100644 (file)
@@ -20,6 +20,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/babeld
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Routing and Redirection
   TITLE:=A loop-free distance-vector routing protocol
   URL:=http://www.pps.jussieu.fr/~jch/software/babel/
   MAINTAINER:=Gabriel Kerneis <kerneis@pps.jussieu.fr>
index 821e33a..db1bc37 100644 (file)
@@ -34,6 +34,7 @@ define Package/batmand
 $(call Package/batmand/Default)
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Routing and Redirection
   DEPENDS:=+libpthread +kmod-tun
   TITLE:=B.A.T.M.A.N. layer 3 routing daemon
 endef
index b080d65..47f81cd 100644 (file)
@@ -18,15 +18,11 @@ PKG_BUILD_DEPENDS:=libncurses libreadline
 include $(INCLUDE_DIR)/package.mk
 
 define Package/bird/Default
-  SECTION:=net
-  CATEGORY:=Network
   TITLE:=The BIRD Internet Routing Daemon
   URL:=http://bird.network.cz/
 endef
 
 define Package/birdc/Default
-  SECTION:=net
-  CATEGORY:=Network
   TITLE:=The BIRD command-line client
   URL:=http://bird.network.cz/
   DEPENDS:= +libreadline +libncurses
@@ -62,22 +58,32 @@ endef
 
 define Package/bird4
 $(call Package/bird/Default)
+  SECTION:=net
+  CATEGORY:=Network
+  SUBMENU:=Routing and Redirection
   TITLE+= (IPv4)
 endef
 
 define Package/birdc4
 $(call Package/birdc/Default)
+  SECTION:=net
+  CATEGORY:=Network
+  SUBMENU:=Routing and Redirection
   TITLE+= (IPv4)
   DEPENDS+= +bird4
 endef
 
 define Package/bird6
 $(call Package/bird/Default)
+  SECTION:=ipv6
+  CATEGORY:=IPv6
   TITLE+= (IPv6)
 endef
 
 define Package/birdc6
 $(call Package/birdc/Default)
+  SECTION:=ipv6
+  CATEGORY:=IPv6
   TITLE+= (IPv6)
   DEPENDS+= +bird6
 endef
index fa57ca0..c182d8e 100644 (file)
@@ -34,6 +34,7 @@ define Package/bmxd
 $(call Package/bmxd/Default)
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Routing and Redirection
   DEPENDS:=+kmod-tun
   TITLE:=B.a.t.M.a.n. eXperimental (BMX) layer 3 routing daemon
 endef
index 973d7a3..e7fb1b1 100644 (file)
@@ -182,6 +182,7 @@ endef
 define Package/net-tools-route
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Routing and Redirection
   TITLE:=net-tools - route
   URL:=http://www.tazenda.demon.co.uk/phil/net-tools
 endef
index 71160b6..c822b8c 100644 (file)
@@ -19,6 +19,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/redir
        SECTION:=net
        CATEGORY:=Network
+       SUBMENU:=Routing and Redirection
        TITLE=Redirect TCP connections
        URL:=http://sammy.net/~sammy/hacks
 endef
index 235068f..75d05e3 100755 (executable)
@@ -21,6 +21,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/rinetd
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Routing and Redirection
   TITLE:=rinetd - Internet Redirection Server
   URL:=http://www.boutell.com/rinetd/
 endef
index fbd5794..8626b66 100644 (file)
@@ -19,6 +19,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/smcroute
        SECTION:=net
        CATEGORY:=Network
+       SUBMENU:=Routing and Redirection
        TITLE:=Static multicast routing daemon
        URL:=http://www.cschill.de/smcroute/
 endef
index 9265c42..9fcdd6c 100644 (file)
@@ -20,6 +20,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/udp-broadcast-relay
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Routing and Redirection
   TITLE:=listens for packets on a specified UDP broadcast port
   URL:=http://www.joachim-breitner.de/udp-broadcast-relay/
 endef
index 6237f81..daff298 100644 (file)
@@ -20,6 +20,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/vrrpd
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Routing and Redirection
   TITLE:=Virtual Router Redundancy Protocol daemon
   URL:=http://www.sourceforge.net/projects/vrrpd
 endef
index 9015046..01977e3 100644 (file)
@@ -29,6 +29,7 @@ define Package/wing
        TITLE:=Wireless mesh networking toolkit
        SECTION:=net
        CATEGORY:=Network
+       SUBMENU:=Routing and Redirection
        MAINTAINER:=Roberto Riggio <roberto.riggio@create-net.org>
        DEPENDS:=+kmod-tun +libpcap +libstdcpp
        URL:=http://www.wing-project.org/