[packages] avahi fix for Ticket #11039 -- rlimit-nproc set too low
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 22 Aug 2012 09:59:23 +0000 (09:59 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 22 Aug 2012 09:59:23 +0000 (09:59 +0000)
This patches the /etc/avahi/avahi-daemon.conf file, setting the rlimit-nproc parameter to 3.
Thepresent value for rlimit-nproc of 1 is too low and  can cause the avahi-daemon to refuse to start, with a message:
chroot.c: fork() failed: Resource temporarily unavailable

This patch changes the setting of rlimit-nproc to 3, the same setting as
is in the default avahi-daemon.conf file.

The issue was reported in Ticket #11039.

Signed-off-by Mike Brady <mikebrady@eircom.net>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@33221 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/avahi/Makefile
libs/avahi/files/avahi-daemon.conf

index 4fd5f80..2845c55 100644 (file)
@@ -16,7 +16,7 @@ endif
 
 PKG_NAME:=avahi
 PKG_VERSION:=0.6.31
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
index cf13856..4ef64df 100644 (file)
@@ -25,4 +25,4 @@ rlimit-data=4194304
 rlimit-fsize=0
 rlimit-nofile=30
 rlimit-stack=4194304
-rlimit-nproc=1
+rlimit-nproc=3