fix some misuses of the recently added EXTRA_{CFLAGS,CPPFLAGS,LDFLAGS} variables
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 1 Feb 2007 23:48:59 +0000 (23:48 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 1 Feb 2007 23:48:59 +0000 (23:48 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@6248 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/postgresql/Makefile
net/pptpd/Makefile
net/wiviz/Makefile
net/wrt-radauth/Makefile
utils/hdparm/Makefile
utils/procps/Makefile

index 7bb3f53..c199856 100644 (file)
@@ -46,9 +46,9 @@ endef
 define Build/Configure
        (cd $(PKG_BUILD_DIR); rm -f config.cache; \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)" \
-               CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="$$$$CPPFLAGS $(EXTRA_CPPFLAGS)" \
+               LDFLAGS="$(EXTRA_LDFLAGS)" \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
                        --host=$(GNU_TARGET_NAME) \
index 8827338..1ca2037 100644 (file)
@@ -38,7 +38,7 @@ endef
 
 define Build/Compile
        $(call Build/Compile/Default, \
-               COPTS="\$$$$(EXTRA_CFLAGS)" \
+               COPTS="$(TARGET_CFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                INSTALL="install" \
                all install \
index ff7cc5f..da75545 100644 (file)
@@ -31,8 +31,8 @@ endef
 
 define Build/Compile
        $(call Build/Compile/Default, \
-               CCOPTS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)" \
-               INCLUDE="" \
+               CCOPTS="$(TARGET_CFLAGS)" \
+               INCLUDE="$(EXTRA_CPPFLAGS)" \
                LDFLAGS="$(EXTRA_LDFLAGS)" \
        )
 endef
index 1cfe084..b0e1646 100644 (file)
@@ -35,8 +35,8 @@ endef
   
 define Build/Compile
        $(call Build/Compile/Default, \
-               CFLAGS="\$$$$(EXTRA_CFLAGS)" \
-               LDFLAGS="\$$$$(EXTRA_LDFLAGS)" \
+               CFLAGS="$(EXTRA_CFLAGS)" \
+               LDFLAGS="$(EXTRA_LDFLAGS)" \
        )
 endef
 
index c74ec81..0fef9b6 100644 (file)
@@ -37,8 +37,8 @@ endef
 
 define Build/Compile
        $(call Build/Compile/Default, \
-               CFLAGS="\$$$$(EXTRA_CFLAGS)" \
-               LDFLAGS="\$$$$(EXTRA_LDFLAGS)" \
+               CFLAGS="$(EXTRA_CFLAGS)" \
+               LDFLAGS="$(EXTRA_LDFLAGS)" \
        )
 endef
 
index 1eb89bf..3650732 100644 (file)
@@ -43,7 +43,7 @@ endef
 define Build/Compile
        $(call Build/Compile/Default, \
                CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="$(EXTRA_CFLAGS)" \
+               CPPFLAGS="$(EXTRA_CPPFLAGS)" \
                LDFLAGS="$(EXTRA_LDFLAGS)" \
        )
 endef