[include] adds wrapper for uapi directory
authorJohn Crispin <blogic@openwrt.org>
Sat, 15 Dec 2012 01:59:14 +0000 (01:59 +0000)
committerJohn Crispin <blogic@openwrt.org>
Sat, 15 Dec 2012 01:59:14 +0000 (01:59 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34683 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel.mk

index 589db02..eabf948 100644 (file)
@@ -35,6 +35,7 @@ else
   endif
   KERNEL_BUILD_DIR ?= $(BUILD_DIR)/linux-$(BOARD)$(if $(SUBTARGET),_$(SUBTARGET))
   LINUX_DIR ?= $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)
+  LINUX_UAPI_DIR=$(firstword $(wildcard $(LINUX_DIR)/include/uapi $(LINUX_DIR)/include))
 
   LINUX_VERMAGIC:=$(strip $(shell cat $(LINUX_DIR)/.vermagic 2>/dev/null))
   LINUX_VERMAGIC:=$(if $(LINUX_VERMAGIC),$(LINUX_VERMAGIC),unknown)