kamailio4: upgrade to 4.1.0
authorJiri Slachta <slachta@cesnet.cz>
Sun, 8 Dec 2013 21:05:51 +0000 (22:05 +0100)
committerJiri Slachta <slachta@cesnet.cz>
Sun, 8 Dec 2013 21:05:51 +0000 (22:05 +0100)
Signed-off-by: Jiri Slachta <slachta@cesnet.cz>
net/kamailio-4.0.x/Makefile [deleted file]
net/kamailio-4.0.x/files/kamailio.default [deleted file]
net/kamailio-4.0.x/files/kamailio.init [deleted file]
net/kamailio-4.0.x/patches/001-mod-json-fix-library-name.patch [deleted file]
net/kamailio-4.0.x/patches/002-mod-jsonrpc-fix-library-name.patch [deleted file]
net/kamailio-4.1.x/Makefile [new file with mode: 0644]
net/kamailio-4.1.x/files/kamailio.default [new file with mode: 0644]
net/kamailio-4.1.x/files/kamailio.init [new file with mode: 0644]
net/kamailio-4.1.x/patches/001-mod-json-fix-library-name.patch [new file with mode: 0644]
net/kamailio-4.1.x/patches/002-mod-jsonrpc-fix-library-name.patch [new file with mode: 0644]

diff --git a/net/kamailio-4.0.x/Makefile b/net/kamailio-4.0.x/Makefile
deleted file mode 100644 (file)
index a19b9d2..0000000
+++ /dev/null
@@ -1,246 +0,0 @@
-#
-# Copyright (C) 2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=kamailio4
-PKG_VERSION:=4.0.4
-PKG_RELEASE:=2
-
-PKG_SOURCE_URL:=http://www.kamailio.org/pub/kamailio/$(PKG_VERSION)/src/
-PKG_SOURCE:=kamailio-$(PKG_VERSION)$(PKG_VARIANT)_src.tar.gz
-PKG_MD5SUM:=e625f52d53ed00da97a50b3ecd451b8d
-
-INCL_MODULES:=
-KAM_MODULES:=
-
-include $(INCLUDE_DIR)/nls.mk
-include $(INCLUDE_DIR)/package.mk
-
-TARGET_CFLAGS += $(FPIC)
-PREBUILT_STAMP=$(STAGING_DIR)/stamp/.$(PKG_NAME)_prebuilt
-TAR_CMD:=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components 1 $(TAR_OPTIONS)
-
-define Package/kamailio4/Default
-  SECTION:=net
-  CATEGORY:=Network
-  SUBMENU:=Telephony
-  URL:=http://www.kamailio.org/
-  MAINTAINER:=Jiri Slachta <slachta@cesnet.cz>
-  DEPENDS:=$(ICONV_DEPENDS) +libncurses +libpthread +libreadline +libxml2
-endef
-
-define Package/kamailio4
-$(call Package/kamailio4/Default)
-  TITLE:=Mature and flexible open source SIP server, v4.0.x
-  MENU:=1
-endef
-
-define Package/kamailio4/conffiles
-/etc/default/kamailio
-/etc/kamailio/kamailio.cfg
-/etc/kamailio/kamailio-advanced.cfg
-/etc/kamailio/dictionary.kamailio
-endef
-
-define Package/kamailio4-tools
-$(call Package/kamailio4/Default)
-  TITLE:=Kamailio4 control tools
-  DEPENDS:=kamailio4 +bash
-endef
-
-define Package/kamailio4-tools/conffiles
-/etc/kamailio/kamctlrc
-endef
-
-define Package/kamailio4/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) \
-               $(PKG_INSTALL_DIR)/usr/sbin/{kamailio,kamcmd} \
-               $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/usr/lib/kamailio/modules
-       $(INSTALL_BIN) \
-               $(PKG_INSTALL_DIR)/usr/lib/kamailio/lib*.so* \
-               $(1)/usr/lib/kamailio/
-       $(INSTALL_DIR) $(1)/etc/kamailio
-       $(CP) \
-               $(PKG_INSTALL_DIR)/etc/kamailio/{kamailio-advanced.cfg,kamailio.cfg} \
-               $(1)/etc/kamailio/
-       $(INSTALL_DIR) $(1)/etc/kamailio
-       $(CP) \
-               $(PKG_INSTALL_DIR)/etc/kamailio/dictionary.kamailio \
-               $(1)/etc/kamailio/
-       $(INSTALL_DIR) $(1)/etc/default
-       $(CP) \
-               ./files/kamailio.default \
-               $(1)/etc/default/kamailio
-       $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) \
-               ./files/kamailio.init \
-               $(1)/etc/init.d/kamailio
-endef
-
-define Package/kamailio4-tools/install
-       $(INSTALL_DIR) $(1)/etc/kamailio
-       $(CP) \
-               $(PKG_BUILD_DIR)/utils/kamctl/kamctlrc \
-               $(1)/etc/kamailio/
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) \
-               $(PKG_INSTALL_DIR)/usr/sbin/kam{ctl,dbctl} \
-               $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/usr/lib/kamailio
-       $(CP) \
-               $(PKG_INSTALL_DIR)/usr/lib/kamailio/kamctl \
-               $(1)/usr/lib/kamailio/
-endef
-
-define BuildPlugin
-  define Package/kamailio4-mod-$(1)
-    $$(call Package/kamailio4/Default)
-    TITLE:= kamailio4 $(3) module
-    DEPENDS:=kamailio4 $$(foreach m,$(4),+kamailio4-mod-$$m) $(5)
-  endef
-
-  define Package/kamailio4-mod-$(1)/install
-       $(INSTALL_DIR) $$(1)/usr/lib/kamailio/modules
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/kamailio/modules/$(2).so $$(1)/usr/lib/kamailio/modules/
-  endef
-
-  INCL_MODULES+=$(2)
-  KAM_MODULES+=kamailio4-mod-$(1)
-endef
-
-$(eval $(call BuildPlugin,acc,acc,Accounting,tm,))
-$(eval $(call BuildPlugin,acc-radius,acc_radius,Accounting for RADIUS backend,acc,+libradiusclient-ng))
-$(eval $(call BuildPlugin,alias-db,alias_db,Database-backend aliases,db-sqlite,))
-$(eval $(call BuildPlugin,auth,auth,Authentication Framework,,))
-$(eval $(call BuildPlugin,auth-db,auth_db,Database-backend authentication,auth db-sqlite,))
-$(eval $(call BuildPlugin,auth-diameter,auth_diameter,Diameter-backend authentication,sl,))
-$(eval $(call BuildPlugin,auth-radius,auth_radius,RADIUS-backend authentication,auth,+libradiusclient-ng))
-$(eval $(call BuildPlugin,avpops,avpops,AVP operation,,))
-$(eval $(call BuildPlugin,benchmark,benchmark,Config benchmark,,))
-$(eval $(call BuildPlugin,cfgutils,cfgutils,Config utilities,,))
-$(eval $(call BuildPlugin,cfg-db,cfg_db,Load core and module parameters from database,db-sqlite,))
-$(eval $(call BuildPlugin,cfg-rpc,cfg_rpc,Update core and module parameters at runtime via RPC interface,,))
-$(eval $(call BuildPlugin,corex,corex,Legacy functions,,))
-$(eval $(call BuildPlugin,ctl,ctl,BINRPC transport interface,,))
-$(eval $(call BuildPlugin,db-flatstore,db_flatstore,Fast writing-only text database-backed,,))
-$(eval $(call BuildPlugin,db-mysql,db_mysql,MySQL database-backend,,+libmysqlclient))
-$(eval $(call BuildPlugin,db-postgres,db_postgres,PostgreSQL Database-backend,,+libpq))
-$(eval $(call BuildPlugin,db-sqlite,db_sqlite,Sqlite DB support,,+libsqlite3))
-$(eval $(call BuildPlugin,db-text,db_text,Text database-backend,,))
-$(eval $(call BuildPlugin,db-unixodbc,db_unixodbc,UnixODBC Database-backend,,+unixodbc))
-$(eval $(call BuildPlugin,dialog,dialog,Dialog support,rr tm,))
-$(eval $(call BuildPlugin,dialog_ng,dialog,Dialog support,rr tm,))
-$(eval $(call BuildPlugin,dialplan,dialplan,Dialplan management,,+libpcre))
-$(eval $(call BuildPlugin,dispatcher,dispatcher,Dispatcher,,))
-$(eval $(call BuildPlugin,diversion,diversion,Diversion header insertion,,))
-$(eval $(call BuildPlugin,domain,domain,Multi-domain support,,))
-$(eval $(call BuildPlugin,domainpolicy,domainpolicy,Domain policy,,))
-$(eval $(call BuildPlugin,enum,enum,ENUM lookup,,))
-$(eval $(call BuildPlugin,exec,exec,External exec,,))
-$(eval $(call BuildPlugin,group,group,Database-backend user-groups,,))
-$(eval $(call BuildPlugin,h350,h350,H.350,ldap,+libopenldap))
-$(eval $(call BuildPlugin,htable,htable,Hash Table,,))
-$(eval $(call BuildPlugin,imc,imc,IM conferencing,db-mysql tm,))
-$(eval $(call BuildPlugin,ipops,ipops,IP and IPv6 operations,,))
-$(eval $(call BuildPlugin,json,json,Access to JSON document attributes,,+libjson))
-$(eval $(call BuildPlugin,kex,kex,Core extensions,,))
-$(eval $(call BuildPlugin,lcr,lcr,Least Cost Routing,tm,+libpcre))
-$(eval $(call BuildPlugin,ldap,ldap,LDAP connector,,+libopenldap))
-$(eval $(call BuildPlugin,maxfwd,maxfwd,Max-Forward processor,,))
-$(eval $(call BuildPlugin,mediaproxy,mediaproxy,Automatic NAT traversal,dialog,))
-$(eval $(call BuildPlugin,mi-datagram,mi_datagram,Datagram support for Management Interface,,))
-$(eval $(call BuildPlugin,mi-fifo,mi_fifo,FIFO support for Management Interface,,))
-$(eval $(call BuildPlugin,mi-rpc,mi_rpc,RPC support for Management Interface,,))
-$(eval $(call BuildPlugin,misc_radius,misc_radius,Generic RADIUS,,+libradiusclient-ng))
-$(eval $(call BuildPlugin,msilo,msilo,SIP message silo,tm,))
-$(eval $(call BuildPlugin,nat_traversal,nat_traversal,NAT traversal,dialog sl tm,))
-$(eval $(call BuildPlugin,nathelper,nathelper,NAT traversal helper,,+rtpproxy))
-$(eval $(call BuildPlugin,path,path,SIP path insertion,rr,))
-$(eval $(call BuildPlugin,pdt,pdt,Prefix-to-Domain translator,,))
-$(eval $(call BuildPlugin,peering,peering,Perring,,+libradiusclient-ng))
-$(eval $(call BuildPlugin,permissions,permissions,Permissions control,,))
-$(eval $(call BuildPlugin,pike,pike,Flood detector,,))
-$(eval $(call BuildPlugin,presence,presence,Presence server,sl tm,+libxml2))
-$(eval $(call BuildPlugin,presence-dialoginfo,presence_dialoginfo,Dialog Event presence,presence,))
-$(eval $(call BuildPlugin,presence-mwi,presence_mwi,Message Waiting Indication presence,presence,))
-$(eval $(call BuildPlugin,presence-xml,presence_xml,XCAP presence,presence xcap-client,))
-$(eval $(call BuildPlugin,pua,pua,Presence User Agent,tm,+libxml2))
-$(eval $(call BuildPlugin,pua-bla,pua_bla,Bridged Line Appearence PUA,presence pua usrloc,))
-$(eval $(call BuildPlugin,pua-dialoginfo,pua_dialoginfo,Dialog Event PUA,dialog pua,))
-$(eval $(call BuildPlugin,pua-mi,pua_mi,PUA Management Interface,pua,))
-$(eval $(call BuildPlugin,pua-usrloc,pua_usrloc,PUA User Location,pua usrloc,))
-$(eval $(call BuildPlugin,pua-xmpp,pua_xmpp,PUA XMPP,presence pua xmpp,))
-$(eval $(call BuildPlugin,pv,pv,Pseudo-Variables,,))
-$(eval $(call BuildPlugin,qos,qos,QoS control,dialog,))
-$(eval $(call BuildPlugin,ratelimit,ratelimit,Traffic shapping,,))
-$(eval $(call BuildPlugin,regex,regex,Regular Expression,,+libpcre))
-$(eval $(call BuildPlugin,registrar,registrar,SIP Registrar,usrloc,))
-$(eval $(call BuildPlugin,rls,rls,Resource List Server,presence pua tm,+libxml2))
-$(eval $(call BuildPlugin,rr,rr,Record-Route and Route,,))
-$(eval $(call BuildPlugin,rtimer,rtimer,Routing Timer,,))
-$(eval $(call BuildPlugin,rtpproxy,rtpproxy,RTP proxy,tm,))
-$(eval $(call BuildPlugin,sanity,sanity,SIP sanity checks,sl,))
-$(eval $(call BuildPlugin,sipcapture,sipcapture,SIP capture,,))
-$(eval $(call BuildPlugin,siptrace,siptrace,SIP trace,,))
-$(eval $(call BuildPlugin,siputils,siputils,SIP utilities,sl,))
-$(eval $(call BuildPlugin,sl,sl,Stateless replier,,))
-$(eval $(call BuildPlugin,sms,sms,SIP-to-SMS IM gateway,tm,))
-$(eval $(call BuildPlugin,speeddial,speeddial,Per-user speed-dial controller,,))
-$(eval $(call BuildPlugin,sqlops,sqlops,SQL operations,,))
-$(eval $(call BuildPlugin,statistics,statistics,Script statistics,,))
-$(eval $(call BuildPlugin,sst,sst,SIP Session Timer,dialog sl,))
-$(eval $(call BuildPlugin,textops,textops,Text operations,,))
-$(eval $(call BuildPlugin,tls,tls,TLS operations,,+libopenssl))
-$(eval $(call BuildPlugin,topoh,topoh,Topology hiding,rr,))
-$(eval $(call BuildPlugin,tm,tm,Transaction,,))
-$(eval $(call BuildPlugin,tmx,tmx,Transaction module extensions,,))
-$(eval $(call BuildPlugin,uac,uac,User Agent Client,tm,))
-$(eval $(call BuildPlugin,uac-redirect,uac_redirect,User Agent Client redirection,tm,))
-$(eval $(call BuildPlugin,uri-db,uri_db,Database-backend SIP URI checking,,))
-$(eval $(call BuildPlugin,userblacklist,userblacklist,User blacklists,,))
-$(eval $(call BuildPlugin,usrloc,usrloc,User location,,))
-$(eval $(call BuildPlugin,utils,utils,Misc utilities,,+libcurl +libxml2))
-$(eval $(call BuildPlugin,xcap-client,xcap_client,XCAP Client,,+libcurl))
-$(eval $(call BuildPlugin,xlog,xlog,Advanced logger,,))
-$(eval $(call BuildPlugin,xmpp,xmpp,SIP-to-XMPP Gateway,tm,+libexpat))
-
-PKG_MAKE_ARGS:= \
-       prefix=/ \
-       cfg_dir=/etc/kamailio/ \
-       bin_dir=/usr/sbin/ \
-       data_dir=/var/lib/kamailio/ \
-       lib_dir=/usr/lib/kamailio/ \
-       modules_dir=/usr/lib/kamailio/ \
-       include_modules="$(INCL_MODULES)" \
-       cfg_target:=/etc/kamailio/ \
-       TLS_HOOKS=1 \
-       extra_defs="-DUSE_PTHREAD_MUTEX " \
-       CFLAGS="$(TARGET_CFLAGS)" \
-       LOCALBASE="$(STAGING_DIR)/usr" \
-       SYSBASE="$(STAGING_DIR)/usr" \
-       PCREDEFS:="$(TARGET_CPPFLAGS)" \
-       PCRELIBS:="$(TARGET_LDFLAGS)" \
-       CROSS_COMPILE=$(TARGET_CROSS) \
-       CC="$(TARGET_CC)" \
-       ARCH="$(ARCH)"  \
-       DESTDIR=$(PKG_INSTALL_DIR) \
-       quiet=verbose
-
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) $(PKG_MAKE_ARGS) \
-               EXTRA_LIBS=-L$(STAGING_DIR)/usr/lib/ \
-               all
-       $(MAKE) -C $(PKG_BUILD_DIR) $(PKG_MAKE_ARGS) \
-               install
-endef
-
-$(eval $(call BuildPackage,kamailio4))
-$(eval $(call BuildPackage,kamailio4-tools))
-$(foreach m,$(KAM_MODULES),$(eval $(call BuildPackage,$(m))))
diff --git a/net/kamailio-4.0.x/files/kamailio.default b/net/kamailio-4.0.x/files/kamailio.default
deleted file mode 100644 (file)
index a61617b..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-# OPTIONS
-# -n COUNT
-# Specifies the number of children processes forked per interface
-# -N COUNT
-# Specifies the number of children processes forked to handle tcp incoming connections
-# -m SIZE
-# Size of the shared memory which will be allocated (in Megabytes).
-# -u UID
-# Changes the user id under which 
-# -g GID
-# Changes the group id under which 
-
-OPTIONS="-n 4 -m 4 - m 8"
diff --git a/net/kamailio-4.0.x/files/kamailio.init b/net/kamailio-4.0.x/files/kamailio.init
deleted file mode 100644 (file)
index 5a382ae..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2012 OpenWrt.org
-START=99 
-APP=kamailio
-BIN_FILE="/usr/sbin/"$APP
-PID_FILE="/var/run/"$APP".pid"
-
-start() {
-       start-stop-daemon -S -x $BIN_FILE -p $PID_FILE -b -m
-}
-
-stop() {
-       start-stop-daemon -K -x $BIN_FILE -p $PID_FILE -q
-       rm -rf $PID_FILE
-}
diff --git a/net/kamailio-4.0.x/patches/001-mod-json-fix-library-name.patch b/net/kamailio-4.0.x/patches/001-mod-json-fix-library-name.patch
deleted file mode 100644 (file)
index 772aaa2..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
---- kamailio4-4.0.1/modules/json/Makefile      2013-04-25 16:56:29.000000000 +0200
-+++ kamailio4-next/modules/json/Makefile       2013-05-31 10:54:42.125995025 +0200
-@@ -11,12 +11,12 @@ LIBS=
- BUILDER = $(shell which pkg-config)
- ifeq ($(BUILDER),)
--      DEFS+=-I/usr/include/json -I$(LOCALBASE)/include/json \
-+      DEFS+=-I/usr/include/json-c -I$(LOCALBASE)/include/json-c \
-        -I$(LOCALBASE)/include
--      LIBS+=-L$(SYSBASE)/include/lib -L$(LOCALBASE)/lib -ljson
-+      LIBS+=-L$(SYSBASE)/include/lib -L$(LOCALBASE)/lib -ljson-c
- else
--      DEFS+= $(shell pkg-config --cflags json)
--      LIBS+= $(shell pkg-config --libs json)
-+      DEFS+= $(shell pkg-config --cflags json-c)
-+      LIBS+= $(shell pkg-config --libs json-c)
- endif
- DEFS+=-DKAMAILIO_MOD_INTERFACE
diff --git a/net/kamailio-4.0.x/patches/002-mod-jsonrpc-fix-library-name.patch b/net/kamailio-4.0.x/patches/002-mod-jsonrpc-fix-library-name.patch
deleted file mode 100644 (file)
index d0dc962..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
---- kamailio4-4.0.1/modules/jsonrpc-c/Makefile 2013-04-25 16:56:29.000000000 +0200
-+++ kamailio4-next/modules/jsonrpc-c/Makefile  2013-05-31 10:58:00.689999015 +0200
-@@ -11,12 +11,12 @@ LIBS=-lm
- BUILDER = $(shell which pkg-config)
- ifeq ($(BUILDER),)
--      DEFS+=-I/usr/include/json -I$(LOCALBASE)/include/json \
-+      DEFS+=-I/usr/include/json-c -I$(LOCALBASE)/include/json-c \
-        -I$(LOCALBASE)/include
--      LIBS+=-L$(SYSBASE)/include/lib -L$(LOCALBASE)/lib -levent -ljson
-+      LIBS+=-L$(SYSBASE)/include/lib -L$(LOCALBASE)/lib -levent -ljson-c
- else
--      DEFS+= $(shell pkg-config --cflags json)
--      LIBS+= $(shell pkg-config --libs json)
-+      DEFS+= $(shell pkg-config --cflags json-c)
-+      LIBS+= $(shell pkg-config --libs json-c)
-       DEFS+= $(shell pkg-config --cflags libevent)
-       LIBS+= $(shell pkg-config --libs libevent)
- endif
diff --git a/net/kamailio-4.1.x/Makefile b/net/kamailio-4.1.x/Makefile
new file mode 100644 (file)
index 0000000..1d2599d
--- /dev/null
@@ -0,0 +1,246 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=kamailio4
+PKG_VERSION:=4.1.0
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=http://www.kamailio.org/pub/kamailio/$(PKG_VERSION)/src/
+PKG_SOURCE:=kamailio-$(PKG_VERSION)$(PKG_VARIANT)_src.tar.gz
+PKG_MD5SUM:=a7d0e685c4890895c6a8623777a111a6
+
+INCL_MODULES:=
+KAM_MODULES:=
+
+include $(INCLUDE_DIR)/nls.mk
+include $(INCLUDE_DIR)/package.mk
+
+TARGET_CFLAGS += $(FPIC)
+PREBUILT_STAMP=$(STAGING_DIR)/stamp/.$(PKG_NAME)_prebuilt
+TAR_CMD:=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components 1 $(TAR_OPTIONS)
+
+define Package/kamailio4/Default
+  SECTION:=net
+  CATEGORY:=Network
+  SUBMENU:=Telephony
+  URL:=http://www.kamailio.org/
+  MAINTAINER:=Jiri Slachta <slachta@cesnet.cz>
+  DEPENDS:=$(ICONV_DEPENDS) +libncurses +libpthread +libreadline +libxml2
+endef
+
+define Package/kamailio4
+$(call Package/kamailio4/Default)
+  TITLE:=Mature and flexible open source SIP server, v4.1.x
+  MENU:=1
+endef
+
+define Package/kamailio4/conffiles
+/etc/default/kamailio
+/etc/kamailio/kamailio.cfg
+/etc/kamailio/kamailio-advanced.cfg
+/etc/kamailio/dictionary.kamailio
+endef
+
+define Package/kamailio4-tools
+$(call Package/kamailio4/Default)
+  TITLE:=Kamailio4 control tools
+  DEPENDS:=kamailio4 +bash
+endef
+
+define Package/kamailio4-tools/conffiles
+/etc/kamailio/kamctlrc
+endef
+
+define Package/kamailio4/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/sbin/{kamailio,kamcmd} \
+               $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/lib/kamailio/modules
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/lib/kamailio/lib*.so* \
+               $(1)/usr/lib/kamailio/
+       $(INSTALL_DIR) $(1)/etc/kamailio
+       $(CP) \
+               $(PKG_INSTALL_DIR)/etc/kamailio/{kamailio-advanced.cfg,kamailio.cfg} \
+               $(1)/etc/kamailio/
+       $(INSTALL_DIR) $(1)/etc/kamailio
+       $(CP) \
+               $(PKG_INSTALL_DIR)/etc/kamailio/dictionary.kamailio \
+               $(1)/etc/kamailio/
+       $(INSTALL_DIR) $(1)/etc/default
+       $(CP) \
+               ./files/kamailio.default \
+               $(1)/etc/default/kamailio
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) \
+               ./files/kamailio.init \
+               $(1)/etc/init.d/kamailio
+endef
+
+define Package/kamailio4-tools/install
+       $(INSTALL_DIR) $(1)/etc/kamailio
+       $(CP) \
+               $(PKG_BUILD_DIR)/utils/kamctl/kamctlrc \
+               $(1)/etc/kamailio/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/sbin/kam{ctl,dbctl} \
+               $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/lib/kamailio
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/kamailio/kamctl \
+               $(1)/usr/lib/kamailio/
+endef
+
+define BuildPlugin
+  define Package/kamailio4-mod-$(1)
+    $$(call Package/kamailio4/Default)
+    TITLE:= kamailio4 $(3) module
+    DEPENDS:=kamailio4 $$(foreach m,$(4),+kamailio4-mod-$$m) $(5)
+  endef
+
+  define Package/kamailio4-mod-$(1)/install
+       $(INSTALL_DIR) $$(1)/usr/lib/kamailio/modules
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/kamailio/modules/$(2).so $$(1)/usr/lib/kamailio/modules/
+  endef
+
+  INCL_MODULES+=$(2)
+  KAM_MODULES+=kamailio4-mod-$(1)
+endef
+
+$(eval $(call BuildPlugin,acc,acc,Accounting,tm,))
+$(eval $(call BuildPlugin,acc-radius,acc_radius,Accounting for RADIUS backend,acc,+libradiusclient-ng))
+$(eval $(call BuildPlugin,alias-db,alias_db,Database-backend aliases,db-sqlite,))
+$(eval $(call BuildPlugin,auth,auth,Authentication Framework,,))
+$(eval $(call BuildPlugin,auth-db,auth_db,Database-backend authentication,auth db-sqlite,))
+$(eval $(call BuildPlugin,auth-diameter,auth_diameter,Diameter-backend authentication,sl,))
+$(eval $(call BuildPlugin,auth-radius,auth_radius,RADIUS-backend authentication,auth,+libradiusclient-ng))
+$(eval $(call BuildPlugin,avpops,avpops,AVP operation,,))
+$(eval $(call BuildPlugin,benchmark,benchmark,Config benchmark,,))
+$(eval $(call BuildPlugin,cfgutils,cfgutils,Config utilities,,))
+$(eval $(call BuildPlugin,cfg-db,cfg_db,Load core and module parameters from database,db-sqlite,))
+$(eval $(call BuildPlugin,cfg-rpc,cfg_rpc,Update core and module parameters at runtime via RPC interface,,))
+$(eval $(call BuildPlugin,corex,corex,Legacy functions,,))
+$(eval $(call BuildPlugin,ctl,ctl,BINRPC transport interface,,))
+$(eval $(call BuildPlugin,db-flatstore,db_flatstore,Fast writing-only text database-backed,,))
+$(eval $(call BuildPlugin,db-mysql,db_mysql,MySQL database-backend,,+libmysqlclient))
+$(eval $(call BuildPlugin,db-postgres,db_postgres,PostgreSQL Database-backend,,+libpq))
+$(eval $(call BuildPlugin,db-sqlite,db_sqlite,Sqlite DB support,,+libsqlite3))
+$(eval $(call BuildPlugin,db-text,db_text,Text database-backend,,))
+$(eval $(call BuildPlugin,db-unixodbc,db_unixodbc,UnixODBC Database-backend,,+unixodbc))
+$(eval $(call BuildPlugin,dialog,dialog,Dialog support,rr tm,))
+$(eval $(call BuildPlugin,dialog_ng,dialog,Dialog support,rr tm,))
+$(eval $(call BuildPlugin,dialplan,dialplan,Dialplan management,,+libpcre))
+$(eval $(call BuildPlugin,dispatcher,dispatcher,Dispatcher,,))
+$(eval $(call BuildPlugin,diversion,diversion,Diversion header insertion,,))
+$(eval $(call BuildPlugin,domain,domain,Multi-domain support,,))
+$(eval $(call BuildPlugin,domainpolicy,domainpolicy,Domain policy,,))
+$(eval $(call BuildPlugin,enum,enum,ENUM lookup,,))
+$(eval $(call BuildPlugin,exec,exec,External exec,,))
+$(eval $(call BuildPlugin,group,group,Database-backend user-groups,,))
+$(eval $(call BuildPlugin,h350,h350,H.350,ldap,+libopenldap))
+$(eval $(call BuildPlugin,htable,htable,Hash Table,,))
+$(eval $(call BuildPlugin,imc,imc,IM conferencing,db-mysql tm,))
+$(eval $(call BuildPlugin,ipops,ipops,IP and IPv6 operations,,))
+$(eval $(call BuildPlugin,json,json,Access to JSON document attributes,,+libjson))
+$(eval $(call BuildPlugin,kex,kex,Core extensions,,))
+$(eval $(call BuildPlugin,lcr,lcr,Least Cost Routing,tm,+libpcre))
+$(eval $(call BuildPlugin,ldap,ldap,LDAP connector,,+libopenldap))
+$(eval $(call BuildPlugin,maxfwd,maxfwd,Max-Forward processor,,))
+$(eval $(call BuildPlugin,mediaproxy,mediaproxy,Automatic NAT traversal,dialog,))
+$(eval $(call BuildPlugin,mi-datagram,mi_datagram,Datagram support for Management Interface,,))
+$(eval $(call BuildPlugin,mi-fifo,mi_fifo,FIFO support for Management Interface,,))
+$(eval $(call BuildPlugin,mi-rpc,mi_rpc,RPC support for Management Interface,,))
+$(eval $(call BuildPlugin,misc_radius,misc_radius,Generic RADIUS,,+libradiusclient-ng))
+$(eval $(call BuildPlugin,msilo,msilo,SIP message silo,tm,))
+$(eval $(call BuildPlugin,nat_traversal,nat_traversal,NAT traversal,dialog sl tm,))
+$(eval $(call BuildPlugin,nathelper,nathelper,NAT traversal helper,,+rtpproxy))
+$(eval $(call BuildPlugin,path,path,SIP path insertion,rr,))
+$(eval $(call BuildPlugin,pdt,pdt,Prefix-to-Domain translator,,))
+$(eval $(call BuildPlugin,peering,peering,Perring,,+libradiusclient-ng))
+$(eval $(call BuildPlugin,permissions,permissions,Permissions control,,))
+$(eval $(call BuildPlugin,pike,pike,Flood detector,,))
+$(eval $(call BuildPlugin,presence,presence,Presence server,sl tm,+libxml2))
+$(eval $(call BuildPlugin,presence-dialoginfo,presence_dialoginfo,Dialog Event presence,presence,))
+$(eval $(call BuildPlugin,presence-mwi,presence_mwi,Message Waiting Indication presence,presence,))
+$(eval $(call BuildPlugin,presence-xml,presence_xml,XCAP presence,presence xcap-client,))
+$(eval $(call BuildPlugin,pua,pua,Presence User Agent,tm,+libxml2))
+$(eval $(call BuildPlugin,pua-bla,pua_bla,Bridged Line Appearence PUA,presence pua usrloc,))
+$(eval $(call BuildPlugin,pua-dialoginfo,pua_dialoginfo,Dialog Event PUA,dialog pua,))
+$(eval $(call BuildPlugin,pua-mi,pua_mi,PUA Management Interface,pua,))
+$(eval $(call BuildPlugin,pua-usrloc,pua_usrloc,PUA User Location,pua usrloc,))
+$(eval $(call BuildPlugin,pua-xmpp,pua_xmpp,PUA XMPP,presence pua xmpp,))
+$(eval $(call BuildPlugin,pv,pv,Pseudo-Variables,,))
+$(eval $(call BuildPlugin,qos,qos,QoS control,dialog,))
+$(eval $(call BuildPlugin,ratelimit,ratelimit,Traffic shapping,,))
+$(eval $(call BuildPlugin,regex,regex,Regular Expression,,+libpcre))
+$(eval $(call BuildPlugin,registrar,registrar,SIP Registrar,usrloc,))
+$(eval $(call BuildPlugin,rls,rls,Resource List Server,presence pua tm,+libxml2))
+$(eval $(call BuildPlugin,rr,rr,Record-Route and Route,,))
+$(eval $(call BuildPlugin,rtimer,rtimer,Routing Timer,,))
+$(eval $(call BuildPlugin,rtpproxy,rtpproxy,RTP proxy,tm,))
+$(eval $(call BuildPlugin,sanity,sanity,SIP sanity checks,sl,))
+$(eval $(call BuildPlugin,sipcapture,sipcapture,SIP capture,,))
+$(eval $(call BuildPlugin,siptrace,siptrace,SIP trace,,))
+$(eval $(call BuildPlugin,siputils,siputils,SIP utilities,sl,))
+$(eval $(call BuildPlugin,sl,sl,Stateless replier,,))
+$(eval $(call BuildPlugin,sms,sms,SIP-to-SMS IM gateway,tm,))
+$(eval $(call BuildPlugin,speeddial,speeddial,Per-user speed-dial controller,,))
+$(eval $(call BuildPlugin,sqlops,sqlops,SQL operations,,))
+$(eval $(call BuildPlugin,statistics,statistics,Script statistics,,))
+$(eval $(call BuildPlugin,sst,sst,SIP Session Timer,dialog sl,))
+$(eval $(call BuildPlugin,textops,textops,Text operations,,))
+$(eval $(call BuildPlugin,tls,tls,TLS operations,,+libopenssl))
+$(eval $(call BuildPlugin,topoh,topoh,Topology hiding,rr,))
+$(eval $(call BuildPlugin,tm,tm,Transaction,,))
+$(eval $(call BuildPlugin,tmx,tmx,Transaction module extensions,,))
+$(eval $(call BuildPlugin,uac,uac,User Agent Client,tm,))
+$(eval $(call BuildPlugin,uac-redirect,uac_redirect,User Agent Client redirection,tm,))
+$(eval $(call BuildPlugin,uri-db,uri_db,Database-backend SIP URI checking,,))
+$(eval $(call BuildPlugin,userblacklist,userblacklist,User blacklists,,))
+$(eval $(call BuildPlugin,usrloc,usrloc,User location,,))
+$(eval $(call BuildPlugin,utils,utils,Misc utilities,,+libcurl +libxml2))
+$(eval $(call BuildPlugin,xcap-client,xcap_client,XCAP Client,,+libcurl))
+$(eval $(call BuildPlugin,xlog,xlog,Advanced logger,,))
+$(eval $(call BuildPlugin,xmpp,xmpp,SIP-to-XMPP Gateway,tm,+libexpat))
+
+PKG_MAKE_ARGS:= \
+       prefix=/ \
+       cfg_dir=/etc/kamailio/ \
+       bin_dir=/usr/sbin/ \
+       data_dir=/var/lib/kamailio/ \
+       lib_dir=/usr/lib/kamailio/ \
+       modules_dir=/usr/lib/kamailio/ \
+       include_modules="$(INCL_MODULES)" \
+       cfg_target:=/etc/kamailio/ \
+       TLS_HOOKS=1 \
+       extra_defs="-DUSE_PTHREAD_MUTEX " \
+       CFLAGS="$(TARGET_CFLAGS)" \
+       LOCALBASE="$(STAGING_DIR)/usr" \
+       SYSBASE="$(STAGING_DIR)/usr" \
+       PCREDEFS:="$(TARGET_CPPFLAGS)" \
+       PCRELIBS:="$(TARGET_LDFLAGS)" \
+       CROSS_COMPILE=$(TARGET_CROSS) \
+       CC="$(TARGET_CC)" \
+       ARCH="$(ARCH)"  \
+       DESTDIR=$(PKG_INSTALL_DIR) \
+       quiet=verbose
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) $(PKG_MAKE_ARGS) \
+               EXTRA_LIBS=-L$(STAGING_DIR)/usr/lib/ \
+               all
+       $(MAKE) -C $(PKG_BUILD_DIR) $(PKG_MAKE_ARGS) \
+               install
+endef
+
+$(eval $(call BuildPackage,kamailio4))
+$(eval $(call BuildPackage,kamailio4-tools))
+$(foreach m,$(KAM_MODULES),$(eval $(call BuildPackage,$(m))))
diff --git a/net/kamailio-4.1.x/files/kamailio.default b/net/kamailio-4.1.x/files/kamailio.default
new file mode 100644 (file)
index 0000000..a61617b
--- /dev/null
@@ -0,0 +1,13 @@
+# OPTIONS
+# -n COUNT
+# Specifies the number of children processes forked per interface
+# -N COUNT
+# Specifies the number of children processes forked to handle tcp incoming connections
+# -m SIZE
+# Size of the shared memory which will be allocated (in Megabytes).
+# -u UID
+# Changes the user id under which 
+# -g GID
+# Changes the group id under which 
+
+OPTIONS="-n 4 -m 4 - m 8"
diff --git a/net/kamailio-4.1.x/files/kamailio.init b/net/kamailio-4.1.x/files/kamailio.init
new file mode 100644 (file)
index 0000000..5a382ae
--- /dev/null
@@ -0,0 +1,15 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2012 OpenWrt.org
+START=99 
+APP=kamailio
+BIN_FILE="/usr/sbin/"$APP
+PID_FILE="/var/run/"$APP".pid"
+
+start() {
+       start-stop-daemon -S -x $BIN_FILE -p $PID_FILE -b -m
+}
+
+stop() {
+       start-stop-daemon -K -x $BIN_FILE -p $PID_FILE -q
+       rm -rf $PID_FILE
+}
diff --git a/net/kamailio-4.1.x/patches/001-mod-json-fix-library-name.patch b/net/kamailio-4.1.x/patches/001-mod-json-fix-library-name.patch
new file mode 100644 (file)
index 0000000..772aaa2
--- /dev/null
@@ -0,0 +1,19 @@
+--- kamailio4-4.0.1/modules/json/Makefile      2013-04-25 16:56:29.000000000 +0200
++++ kamailio4-next/modules/json/Makefile       2013-05-31 10:54:42.125995025 +0200
+@@ -11,12 +11,12 @@ LIBS=
+ BUILDER = $(shell which pkg-config)
+ ifeq ($(BUILDER),)
+-      DEFS+=-I/usr/include/json -I$(LOCALBASE)/include/json \
++      DEFS+=-I/usr/include/json-c -I$(LOCALBASE)/include/json-c \
+        -I$(LOCALBASE)/include
+-      LIBS+=-L$(SYSBASE)/include/lib -L$(LOCALBASE)/lib -ljson
++      LIBS+=-L$(SYSBASE)/include/lib -L$(LOCALBASE)/lib -ljson-c
+ else
+-      DEFS+= $(shell pkg-config --cflags json)
+-      LIBS+= $(shell pkg-config --libs json)
++      DEFS+= $(shell pkg-config --cflags json-c)
++      LIBS+= $(shell pkg-config --libs json-c)
+ endif
+ DEFS+=-DKAMAILIO_MOD_INTERFACE
diff --git a/net/kamailio-4.1.x/patches/002-mod-jsonrpc-fix-library-name.patch b/net/kamailio-4.1.x/patches/002-mod-jsonrpc-fix-library-name.patch
new file mode 100644 (file)
index 0000000..d0dc962
--- /dev/null
@@ -0,0 +1,19 @@
+--- kamailio4-4.0.1/modules/jsonrpc-c/Makefile 2013-04-25 16:56:29.000000000 +0200
++++ kamailio4-next/modules/jsonrpc-c/Makefile  2013-05-31 10:58:00.689999015 +0200
+@@ -11,12 +11,12 @@ LIBS=-lm
+ BUILDER = $(shell which pkg-config)
+ ifeq ($(BUILDER),)
+-      DEFS+=-I/usr/include/json -I$(LOCALBASE)/include/json \
++      DEFS+=-I/usr/include/json-c -I$(LOCALBASE)/include/json-c \
+        -I$(LOCALBASE)/include
+-      LIBS+=-L$(SYSBASE)/include/lib -L$(LOCALBASE)/lib -levent -ljson
++      LIBS+=-L$(SYSBASE)/include/lib -L$(LOCALBASE)/lib -levent -ljson-c
+ else
+-      DEFS+= $(shell pkg-config --cflags json)
+-      LIBS+= $(shell pkg-config --libs json)
++      DEFS+= $(shell pkg-config --cflags json-c)
++      LIBS+= $(shell pkg-config --libs json-c)
+       DEFS+= $(shell pkg-config --cflags libevent)
+       LIBS+= $(shell pkg-config --libs libevent)
+ endif