[packages] collectd: fix fp-layout on big-endian targets (closes: #7707)
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 14 Aug 2010 23:40:04 +0000 (23:40 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 14 Aug 2010 23:40:04 +0000 (23:40 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@22653 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/collectd/Makefile

index 69007d8..ff1ebf0 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=collectd
 PKG_VERSION:=4.9.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://collectd.org/files/
@@ -145,7 +145,6 @@ CONFIGURE_ARGS+= \
        --enable-daemon \
        --enable-getifaddrs \
        --with-nan-emulation \
-       --with-fp-layout=nothing
 
 CONFIGURE_VARS+= \
        CFLAGS="$$$$CFLAGS $(FPIC)" \
@@ -167,6 +166,12 @@ ifneq ($(CONFIG_PACKAGE_collectd-mod-ascent),)
        CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/libxml2"
 endif
 
+ifneq ($(CONFIG_BIG_ENDIAN),)
+  CONFIGURE_ARGS+= --with-fp-layout=endianflip
+else
+  CONFIGURE_ARGS+= --with-fp-layout=nothing
+endif
+
 ifneq ($(CONFIG_PACKAGE_collectd-mod-postgresql),)
   CONFIGURE_ARGS+= --with-libpq="$(STAGING_DIR)/usr/"
 endif