packages/smartmontools: use new service functions
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 9 Nov 2011 23:43:47 +0000 (23:43 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 9 Nov 2011 23:43:47 +0000 (23:43 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@28918 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/smartmontools/Makefile
utils/smartmontools/files/smartd.init

index 16636c6..4f90961 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=smartmontools
 PKG_VERSION:=5.40
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/smartmontools
index 0e8d571..f1453f2 100644 (file)
@@ -1,28 +1,16 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 
 START=95
+
 start() {
-  [ -f /etc/smartd.conf ] || {
-    echo "/etc/smartd.conf does not exist !";
-    exit 0;
-  };
-  [ -d /var/run ] || mkdir -p /var/run
-  [ -x /usr/sbin/smartd ] && /usr/sbin/smartd -q never -p /var/run/smartd.pid
+       service_start /usr/sbin/smartd -q never
 }
 
 stop() {
-  killall smartd
-}
-
-restart() {
-        stop
-        sleep 1
-        start
+       service_stop /usr/sbin/smartd
 }
 
 reload() {
-        kill -HUP `cat /var/run/smartd.pid` &>/dev/null
+       service_reload /usr/sbin/smartd
 }
-
-