oprofile: reduce package size, adjust linking order to find the right libiberty first
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 23 May 2009 00:01:47 +0000 (00:01 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 23 May 2009 00:01:47 +0000 (00:01 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@16006 3c298f89-4303-0410-b956-a3cf2f4a3e73

devel/oprofile/Makefile

index c3368e7..af2558c 100644 (file)
@@ -51,6 +51,8 @@ define Build/Configure
        )
 endef
 
+TARGET_LDFLAGS := -L$(STAGING_DIR)/usr/lib $(TARGET_LDFLAGS)
+
 define Package/oprofile/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) \
@@ -64,7 +66,8 @@ define Package/oprofile/install
 
        $(INSTALL_DIR) $(1)/usr/share/oprofile
        $(CP) \
-               $(PKG_INSTALL_DIR)/usr/share/oprofile/* \
+               $(PKG_INSTALL_DIR)/usr/share/oprofile/stl.pat \
+               $(PKG_INSTALL_DIR)/usr/share/oprofile/$(LINUX_KARCH) \
                $(1)/usr/share/oprofile/
 endef