pwrtray: Add fix backend-only compile
authormb <mb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 2 Oct 2010 17:10:12 +0000 (17:10 +0000)
committermb <mb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 2 Oct 2010 17:10:12 +0000 (17:10 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@23182 3c298f89-4303-0410-b956-a3cf2f4a3e73

Xorg/app/pwrtray/Makefile

index 804464a..eca2c5b 100644 (file)
@@ -76,7 +76,7 @@ define Package/pwrtray-backend/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/pwrtray-backend $(1)/usr/bin/
        $(if $(CONFIG_PACKAGE_libX11),$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/pwrtray-xlock $(1)/usr/bin/)
        $(if $(CONFIG_PACKAGE_pwrtray),$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/pwrtray $(1)/usr/bin/)
-       $(CP) $(PKG_INSTALL_DIR)/usr/share/pwrtray $(1)/usr/share/
+       $(if $(CONFIG_PACKAGE_pwrtray),$(CP) $(PKG_INSTALL_DIR)/usr/share/pwrtray $(1)/usr/share/)
        [ -e $(1)/etc/pwrtray-backendrc ] || \
                $(INSTALL_DATA) ./files/etc/pwrtray-backendrc $(1)/etc/
 endef