[backfire] merge r21589, r21612 and r22102
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 15 Jul 2010 19:08:47 +0000 (19:08 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 15 Jul 2010 19:08:47 +0000 (19:08 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@22209 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/6in4/Makefile [new file with mode: 0644]
package/6in4/files/6in4.hotplug [new file with mode: 0644]
package/6in4/files/6in4.sh [new file with mode: 0755]

diff --git a/package/6in4/Makefile b/package/6in4/Makefile
new file mode 100644 (file)
index 0000000..75e7848
--- /dev/null
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=6in4
+PKG_VERSION:=3
+PKG_RELEASE:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/6in4
+  SECTION:=ipv6
+  CATEGORY:=IPv6
+  DEPENDS:=+ip +kmod-ipv6 +kmod-sit
+  TITLE:=IPv6-in-IPv4 configuration support
+  PKGARCH:=all
+endef
+
+define Package/6in4/description
+Provides support for 6in4 tunnels in /etc/config/network.
+Refer to http://wiki.openwrt.org/doc/uci/network for
+configuration details.
+endef
+
+define Build/Compile
+endef
+
+define Build/Configure
+endef
+
+define Package/6in4/install
+       $(INSTALL_DIR) $(1)/lib/network
+       $(INSTALL_DATA) ./files/6in4.sh $(1)/lib/network/6in4.sh
+       $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+       $(INSTALL_DATA) ./files/6in4.hotplug $(1)/etc/hotplug.d/iface/90-6in4
+endef
+
+$(eval $(call BuildPackage,6in4))
diff --git a/package/6in4/files/6in4.hotplug b/package/6in4/files/6in4.hotplug
new file mode 100644 (file)
index 0000000..96b046d
--- /dev/null
@@ -0,0 +1,44 @@
+#!/bin/sh
+
+if [ "$ACTION" = ifup ]; then
+       . /etc/functions.sh
+
+       include /lib/network
+       scan_interfaces
+
+       update_tunnel() {
+               local cfg="$1"
+
+               local proto
+               config_get proto "$cfg" proto
+               [ "$proto" = 6in4 ] || return 0
+
+               local wandev
+               config_get wandev "$cfg" wan_device "$(find_6in4_wanif)"
+               [ "$wandev" = "$DEVICE" ] || return 0
+
+               local oldip
+               local wanip=$(find_6in4_wanip "$wandev")
+               config_get oldip "$cfg" ipaddr
+
+               [ -n "$wanip" ] && [ "$oldip" != "$wanip" ] && {
+                       local tunnelid
+                       config_get tunnelid "$cfg" tunnelid
+
+                       local username
+                       config_get username "$cfg" username
+
+                       local password
+                       config_get password "$cfg" password
+
+                       [ -n "$tunnelid" ] && [ -n "$username" ] && [ -n "$password" ] && {
+                               password="$(echo -n "$password" | md5sum)"; password="${password%% *}"
+                               uci_set_state network "$cfg" ipaddr "$wanip"
+
+                               ( wget -qO/dev/null "http://ipv4.tunnelbroker.net/ipv4_end.php?ipv4b=AUTO&user_id=$username&pass=$password&tunnel_id=$tunnelid" && ifup "$cfg" )&
+                       }
+               }
+       }
+
+       config_foreach update_tunnel interface
+fi
diff --git a/package/6in4/files/6in4.sh b/package/6in4/files/6in4.sh
new file mode 100755 (executable)
index 0000000..5e416ee
--- /dev/null
@@ -0,0 +1,103 @@
+# 6in4.sh - IPv6-in-IPv4 tunnel backend
+# Copyright (c) 2010 OpenWrt.org
+
+find_6in4_wanif() {
+       local if=$(ip -4 r l e 0/0); if="${if#default via * dev }"; if="${if%% *}"
+       [ -n "$if" ] && grep -qs "^ *$if:" /proc/net/dev && echo "$if"
+}
+
+find_6in4_wanip() {
+       local ip=$(ip -4 a s dev "$1"); ip="${ip#*inet }"
+       echo "${ip%%/[0-9]* brd *}"
+}
+
+# Hook into scan_interfaces() to synthesize a .device option
+# This is needed for /sbin/ifup to properly dispatch control
+# to setup_interface_6in4() even if no .ifname is set in
+# the configuration.
+scan_6in4() {
+       config_set "$1" device "6in4-$1"
+}
+
+coldplug_interface_6in4() {
+       setup_interface_6in4 "6in4-$1" "$1"
+}
+
+setup_interface_6in4() {
+       local iface="$1"
+       local cfg="$2"
+       local link="6in4-$cfg"
+
+       local local4
+       config_get local4 "$cfg" ipaddr
+
+       local remote4
+       config_get remote4 "$cfg" peeraddr
+
+       local local6
+       config_get local6 "$cfg" ip6addr
+
+       local mtu
+       config_get mtu "$cfg" mtu
+
+       local ttl
+       config_get ttl "$cfg" ttl
+
+       local defaultroute
+       config_get_bool defaultroute "$cfg" defaultroute 1
+
+       # If local4 is unset, guess local IPv4 address from the
+       # interface used by the default route.
+       [ -z "$local4" ] && {
+               local wanif=$(find_6in4_wanif)
+               [ -n "$wanif" ] && {
+                       local4=$(find_6in4_wanip "$wanif")
+                       uci_set_state network "$cfg" wan_device "$wanif"
+               }
+       }
+
+       [ -n "$local4" ] && {
+               # creating the tunnel below will trigger a net subsystem event
+               # prevent it from touching or iface by disabling .auto here
+               uci_set_state network "$cfg" ifname $link
+               uci_set_state network "$cfg" auto 0
+
+               ip tunnel add $link mode sit remote $remote4 local $local4 ttl 255
+               ip link set $link up
+               ip link set mtu ${mtu:-1280} dev $link
+               ip tunnel change $link ttl ${ttl:-64}
+               ip addr add $local6 dev $link
+
+               uci_set_state network "$cfg" ipaddr $local4
+               uci_set_state network "$cfg" ip6addr $local6
+
+               [ "$defaultroute" = 1 ] && {
+                       ip -6 route add ::/0 dev $link
+                       uci_set_state network "$cfg" defaultroute 1
+               }
+
+               env -i ACTION="ifup" INTERFACE="$cfg" DEVICE="$link" PROTO=6in4 /sbin/hotplug-call "iface" &
+       } || {
+               echo "Cannot determine local IPv4 address for 6in4 tunnel $cfg - skipping"
+       }
+}
+
+stop_interface_6in4() {
+       local cfg="$1"
+       local link="6in4-$cfg"
+
+       local local6=$(uci_get_state network "$cfg" ip6addr)
+       local defaultroute=$(uci_get_state network "$cfg" defaultroute)
+
+       grep -qs "^ *$link:" /proc/net/dev && {
+               env -i ACTION="ifdown" INTERFACE="$cfg" DEVICE="$link" PROTO=6in4 /sbin/hotplug-call "iface" &
+
+               [ "$defaultroute" = "1" ] && {
+                       ip -6 route del ::/0 dev $link
+               }
+
+               ip addr del $local6 dev $link
+               ip link set $link down
+               ip tunnel del $link
+       }
+}