tcpdump: fix ipv6 support
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 18 Feb 2010 21:38:12 +0000 (21:38 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 18 Feb 2010 21:38:12 +0000 (21:38 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@19711 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/tcpdump/Makefile
net/tcpdump/patches/100-tcpdump_mini.patch

index 910c6c2..5110fb3 100644 (file)
@@ -43,7 +43,9 @@ define Package/tcpdump-mini
   VARIANT:=mini
 endef
 
-CONFIGURE_ARGS += --without-crypto
+CONFIGURE_ARGS += \
+       --without-crypto \
+       --enable-ipv6
 
 CONFIGURE_VARS += \
        BUILD_CC="$(TARGET_CC)" \
index 765821a..9e97593 100644 (file)
                  else if (ISPORT(SIP_PORT))
                        sip_print((const u_char *)(up + 1), length);
                  else if (ISPORT(SYSLOG_PORT))
+--- a/print-ip6.c
++++ b/print-ip6.c
+@@ -160,9 +160,11 @@ ip6_print(register const u_char *bp, reg
+               case IPPROTO_SCTP:
+                       sctp_print(cp, (const u_char *)ip6, len);
+                       return;
++#ifndef TCPDUMP_MINI
+               case IPPROTO_DCCP:
+                       dccp_print(cp, (const u_char *)ip6, len);
+                       return;
++#endif
+               case IPPROTO_TCP:
+                       tcp_print(cp, len, (const u_char *)ip6, fragmented);
+                       return;
+@@ -172,6 +174,7 @@ ip6_print(register const u_char *bp, reg
+               case IPPROTO_ICMPV6:
+                       icmp6_print(cp, len, (const u_char *)ip6, fragmented);
+                       return;
++#ifndef TCPDUMP_MINI
+               case IPPROTO_AH:
+                       advance = ah_print(cp);
+                       nh = *cp;
+@@ -195,7 +198,7 @@ ip6_print(register const u_char *bp, reg
+               case IPPROTO_PIM:
+                       pim_print(cp, len);
+                       return;
+-
++#endif
+               case IPPROTO_OSPF:
+                       ospf6_print(cp, len);
+                       return;
+@@ -207,11 +210,11 @@ ip6_print(register const u_char *bp, reg
+               case IPPROTO_IPV4:
+                       ip_print(gndo, cp, len);
+                       return;
+-
++#ifndef TCPDUMP_MINI
+                 case IPPROTO_PGM:
+                         pgm_print(cp, len, (const u_char *)ip6);
+                         return;
+-
++#endif
+               case IPPROTO_GRE:
+                       gre_print(cp, len);
+                       return;