[packages] i2c-tools: Pass LDFLAGS
authorlars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 7 Jul 2013 20:22:35 +0000 (20:22 +0000)
committerlars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 7 Jul 2013 20:22:35 +0000 (20:22 +0000)
Pass LDFLAGS when building the i2c-tools. This fixes the build under certain
exotic configurations.

git-svn-id: svn://svn.openwrt.org/openwrt/packages@37188 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/i2c-tools/Makefile

index 16feedb..9ef752b 100644 (file)
@@ -68,7 +68,8 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                LINUX="$(LINUX_DIR)" \
                CC="$(TARGET_CC)" \
-               STAGING_DIR="$(STAGING_DIR)"
+               STAGING_DIR="$(STAGING_DIR)" \
+               LDFLAGS="$(TARGET_LDFLAGS)"
        $(Build/Compile/python-smbus)
 endef