[Packages]: Add net/transmission. Thanks, rohde.
authorolli <olli@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 26 May 2008 20:54:21 +0000 (20:54 +0000)
committerolli <olli@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 26 May 2008 20:54:21 +0000 (20:54 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@11271 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/transmission/Makefile [new file with mode: 0644]

diff --git a/net/transmission/Makefile b/net/transmission/Makefile
new file mode 100644 (file)
index 0000000..4b913e1
--- /dev/null
@@ -0,0 +1,55 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=transmission
+PKG_VERSION:=1.21
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://download.m0k.org/transmission/files
+PKG_MD5SUM:=6ec565ac831484098a2db20ea0ca3ac7
+
+PKG_FIXUP = libtool
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/transmission
+  SUBMENU:=BitTorrent
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libcurl +libopenssl +libpthread
+  TITLE:=A free, lightweight BitTorrent client
+  URL:=http://www.transmissionbt.com
+endef
+
+define Package/tranmission/description
+ Transmission is a simple BitTorrent client.
+ It features a very simple, intuitive interface
+ on top on an efficient, cross-platform back-end.
+endef
+
+CONFIGURE_ARGS += \
+       --enable-daemon \
+       --disable-gtk \
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)"
+endef
+
+define Package/transmission/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/daemon/transmission-daemon $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/cli/transmissioncli $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/daemon/transmission-remote $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,transmission))