package: haproxy
authorheil <heil@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 10 Jan 2013 23:49:52 +0000 (23:49 +0000)
committerheil <heil@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 10 Jan 2013 23:49:52 +0000 (23:49 +0000)
 - refresh patches

git-svn-id: svn://svn.openwrt.org/openwrt/packages@35092 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/haproxy/Makefile
net/haproxy/patches/0023-BUG-MINOR-http-don-t-process-abortonclose-when-1.4.22.diff

index 3c5a8a8..85f7a4d 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=haproxy
 PKG_VERSION:=1.4.22
-PKG_RELEASE:=23
+PKG_RELEASE:=24
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://haproxy.1wt.eu/download/1.4/src
index 8e591f4..100672a 100644 (file)
@@ -12,15 +12,11 @@ write before aborting.
 
 This fix should be backported to 1.4 too.
 (cherry picked from commit a7a7ebc38280d7a04192bf95e6852222f4bd8140)
----
- src/session.c |    3 ++-
- 1 files changed, 2 insertions(+), 1 deletions(-)
-
-diff --git a/src/session.c b/src/session.c
-index 239d4f5..6211a45 100644
---- a/src/session.c
-+++ b/src/session.c
-@@ -203,7 +203,8 @@ int sess_update_st_con_tcp(struct session *s, struct stream_interface *si)
+Index: haproxy-1.4.22/src/session.c
+===================================================================
+--- haproxy-1.4.22.orig/src/session.c
++++ haproxy-1.4.22/src/session.c
+@@ -203,7 +203,8 @@ int sess_update_st_con_tcp(struct sessio
        }
  
        /* OK, maybe we want to abort */
@@ -30,6 +26,3 @@ index 239d4f5..6211a45 100644
                     ((req->flags & BF_SHUTW_NOW) && /* FIXME: this should not prevent a connection from establishing */
                      (((req->flags & (BF_OUT_EMPTY|BF_WRITE_ACTIVITY)) == BF_OUT_EMPTY) ||
                       s->be->options & PR_O_ABRT_CLOSE)))) {
--- 
-1.7.1
-