kernel: update from kernel 2.6.32.16 to kernel 2.6.32.25 and refresh patches
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 7 Nov 2010 15:59:49 +0000 (15:59 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 7 Nov 2010 15:59:49 +0000 (15:59 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@23915 3c298f89-4303-0410-b956-a3cf2f4a3e73

30 files changed:
target/linux/adm5120/Makefile
target/linux/ar7/Makefile
target/linux/ar71xx/Makefile
target/linux/au1000/Makefile
target/linux/avr32/Makefile
target/linux/brcm47xx/Makefile
target/linux/brcm47xx/patches-2.6.32/150-cpu_fixes.patch
target/linux/brcm47xx/patches-2.6.32/220-bcm5354.patch
target/linux/brcm47xx/patches-2.6.32/270-ehci-ssb.patch
target/linux/brcm47xx/patches-2.6.32/275-usb2-bcm5354-init.patch
target/linux/brcm47xx/patches-2.6.32/280-activate_ssb_support_in_usb.patch
target/linux/brcm47xx/patches-2.6.32/610-pci_ide_fix.patch
target/linux/brcm47xx/patches-2.6.32/700-ssb-gigabit-ethernet-driver.patch
target/linux/brcm47xx/patches-2.6.32/813-use_netdev_alloc_skb.patch
target/linux/brcm47xx/patches-2.6.32/920-cache-wround.patch
target/linux/brcm63xx/Makefile
target/linux/cobalt/Makefile
target/linux/generic-2.6/patches-2.6.32/025-mips_disable_fpu.patch
target/linux/generic-2.6/patches-2.6.32/030-pci_disable_common_quirks.patch
target/linux/generic-2.6/patches-2.6.32/150-netfilter_imq.patch
target/linux/generic-2.6/patches-2.6.32/260-crypto_optional_tests.patch
target/linux/generic-2.6/patches-2.6.32/975-ssb_update.patch
target/linux/generic-2.6/patches-2.6.32/980-vm_exports.patch
target/linux/ixp4xx/Makefile
target/linux/orion/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/rb532/Makefile
target/linux/x86/Makefile
target/linux/xburst/Makefile

index 0eee0b4..0c319a9 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=2.6.32.16
+LINUX_VERSION:=2.6.32.25
 SUBTARGETS:=router_le router_be
 INITRAMFS_EXTRA_FILES:=
 
index ff9ebe0..40d1621 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ar7
 BOARDNAME:=TI AR7
 FEATURES:=squashfs jffs2 atm
 
-LINUX_VERSION:=2.6.32.16
+LINUX_VERSION:=2.6.32.25
 
 include $(INCLUDE_DIR)/target.mk
 
index 109b36e..7b8fea6 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Atheros AR71xx/AR7240/AR913x
 FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 
-LINUX_VERSION:=2.6.32.16
+LINUX_VERSION:=2.6.32.25
 
 include $(INCLUDE_DIR)/target.mk
 
index f7cec30..ced52ce 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=RMI/AMD AU1x00
 FEATURES:=jffs2 usb pci
 SUBTARGETS=au1500 au1550
 
-LINUX_VERSION:=2.6.32.16
+LINUX_VERSION:=2.6.32.25
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini yamonenv
index 1a8cd55..4aca262 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=avr32
 BOARD:=avr32
 BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
-LINUX_VERSION:=2.6.32.16
+LINUX_VERSION:=2.6.32.25
 
 include $(INCLUDE_DIR)/target.mk
 
index 222f075..7d396d9 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb pcmcia
 
-LINUX_VERSION:=2.6.32.16
+LINUX_VERSION:=2.6.32.25
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
index e6ac4c8..2f5e3a9 100644 (file)
  }
 --- a/arch/mips/mm/tlbex.c
 +++ b/arch/mips/mm/tlbex.c
-@@ -733,6 +733,9 @@ static void __cpuinit build_r4000_tlb_re
+@@ -738,6 +738,9 @@ static void __cpuinit build_r4000_tlb_re
                /* No need for uasm_i_nop */
        }
  
  #ifdef CONFIG_64BIT
        build_get_pmde64(&p, &l, &r, K0, K1); /* get pmd in K1 */
  #else
-@@ -1185,6 +1188,9 @@ build_r4000_tlbchange_handler_head(u32 *
+@@ -1190,6 +1193,9 @@ build_r4000_tlbchange_handler_head(u32 *
                                   struct uasm_reloc **r, unsigned int pte,
                                   unsigned int ptr)
  {
index 1d75e17..ba849dd 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/ssb/driver_chipcommon.c
 +++ b/drivers/ssb/driver_chipcommon.c
-@@ -260,6 +260,8 @@ void ssb_chipco_resume(struct ssb_chipco
+@@ -261,6 +261,8 @@ void ssb_chipco_resume(struct ssb_chipco
  void ssb_chipco_get_clockcpu(struct ssb_chipcommon *cc,
                               u32 *plltype, u32 *n, u32 *m)
  {
@@ -9,7 +9,7 @@
        *n = chipco_read32(cc, SSB_CHIPCO_CLOCK_N);
        *plltype = (cc->capabilities & SSB_CHIPCO_CAP_PLLT);
        switch (*plltype) {
-@@ -283,6 +285,8 @@ void ssb_chipco_get_clockcpu(struct ssb_
+@@ -284,6 +286,8 @@ void ssb_chipco_get_clockcpu(struct ssb_
  void ssb_chipco_get_clockcontrol(struct ssb_chipcommon *cc,
                                 u32 *plltype, u32 *n, u32 *m)
  {
@@ -31,7 +31,7 @@
        }
 --- a/drivers/ssb/main.c
 +++ b/drivers/ssb/main.c
-@@ -1073,6 +1073,8 @@ u32 ssb_clockspeed(struct ssb_bus *bus)
+@@ -1075,6 +1075,8 @@ u32 ssb_clockspeed(struct ssb_bus *bus)
  
        if (bus->chip_id == 0x5365) {
                rate = 100000000;
index d6237f0..f0cbad2 100644 (file)
@@ -29,7 +29,7 @@
        depends on USB
 --- a/drivers/usb/host/ehci-hcd.c
 +++ b/drivers/usb/host/ehci-hcd.c
-@@ -1141,8 +1141,16 @@ MODULE_LICENSE ("GPL");
+@@ -1142,8 +1142,16 @@ MODULE_LICENSE ("GPL");
  #define       PLATFORM_DRIVER         ehci_atmel_driver
  #endif
  
index 3d8327e..6f193bc 100644 (file)
@@ -41,19 +41,18 @@ Signed-off-by: Steve Brown <sbrown@cortland.com>
 -                      ssb_write32(dev, 0x400, tmp);
 -                      tmp = ssb_read32(dev, 0x400);
 -                      printk("USB20H fcr: 0x%0x\n", tmp);
--
++              /* Work around for 5354 failures */
++              if ((dev->id.revision == 2) && (dev->bus->chip_id == 0x5354)) {
++                      /* Change syn01 reg */
++                      tmp = 0x00fe00fe;
++                      ssb_write32(dev, 0x894, tmp);
 -                      /* Change Shim control reg */
 -                      tmp = ssb_read32(dev, 0x304);
 -                      tmp &= ~0x100;
 -                      ssb_write32(dev, 0x304, tmp);
 -                      tmp = ssb_read32(dev, 0x304);
 -                      printk("USB20H shim: 0x%0x\n", tmp);
-+              /* Work around for 5354 failures */
-+              if ((dev->id.revision == 2) && (dev->bus->chip_id == 0x5354)) {
-+                      /* Change syn01 reg */
-+                      tmp = 0x00fe00fe;
-+                      ssb_write32(dev, 0x894, tmp);
-+
 +                      /* Change syn03 reg */
 +                      tmp = ssb_read32(dev, 0x89c);
 +                      tmp |= 0x1;
index f224158..1a50c1a 100644 (file)
@@ -5,7 +5,7 @@ This prevents the options from being delete with make kernel_oldconfig.
 
 --- a/drivers/ssb/Kconfig
 +++ b/drivers/ssb/Kconfig
-@@ -140,6 +140,8 @@ config SSB_DRIVER_MIPS
+@@ -141,6 +141,8 @@ config SSB_DRIVER_MIPS
  config SSB_EMBEDDED
        bool
        depends on SSB_DRIVER_MIPS
index 26ba3b7..f254b20 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/linux/ide.h
 +++ b/include/linux/ide.h
-@@ -195,7 +195,11 @@
+@@ -195,7 +195,11 @@ static inline void ide_std_init_ports(st
        hw->io_ports.ctl_addr = ctl_addr;
  }
  
index dce689f..9f473d9 100644 (file)
@@ -8,7 +8,7 @@
  
  #include <net/checksum.h>
  #include <net/ip.h>
-@@ -457,8 +458,9 @@ static void _tw32_flush(struct tg3 *tp, 
+@@ -457,8 +458,9 @@ static void _tw32_flush(struct tg3 *tp,
  static inline void tw32_mailbox_flush(struct tg3 *tp, u32 off, u32 val)
  {
        tp->write32_mbox(tp, off, val);
@@ -52,7 +52,7 @@
  {
        u32 frame_val;
        unsigned int loops;
-@@ -866,6 +873,11 @@ static int tg3_writephy(struct tg3 *tp, 
+@@ -866,6 +873,11 @@ static int tg3_writephy(struct tg3 *tp,
        return ret;
  }
  
        tw32(GRC_MODE, tp->grc_mode);
  
        if (tp->pci_chip_rev_id == CHIPREV_ID_5705_A0) {
-@@ -6704,9 +6742,12 @@ static int tg3_halt_cpu(struct tg3 *tp, 
+@@ -6704,9 +6742,12 @@ static int tg3_halt_cpu(struct tg3 *tp,
                return -ENODEV;
        }
  
        fw_data = (void *)tp->fw->data;
  
        /* Firmware blob starts with version numbers, followed by
-@@ -6828,6 +6874,11 @@ static int tg3_load_tso_firmware(struct 
+@@ -6828,6 +6874,11 @@ static int tg3_load_tso_firmware(struct
        unsigned long cpu_base, cpu_scratch_base, cpu_scratch_size;
        int err, i;
  
        if (!(tp->tg3_flags & TG3_FLAG_TAGGED_STATUS)) {
                /* All of this garbage is because when using non-tagged
                 * IRQ status the mailbox/status_block protocol the chip
-@@ -9800,6 +9856,11 @@ static int tg3_test_nvram(struct tg3 *tp
+@@ -9801,6 +9857,11 @@ static int tg3_test_nvram(struct tg3 *tp
        if (tp->tg3_flags3 & TG3_FLG3_NO_NVRAM)
                return 0;
  
        if (tg3_nvram_read(tp, 0, &magic) != 0)
                return -EIO;
  
-@@ -10594,7 +10655,7 @@ static int tg3_ioctl(struct net_device *
+@@ -10595,7 +10656,7 @@ static int tg3_ioctl(struct net_device *
                        return -EAGAIN;
  
                spin_lock_bh(&tp->lock);
                spin_unlock_bh(&tp->lock);
  
                data->val_out = mii_regval;
-@@ -10610,7 +10671,7 @@ static int tg3_ioctl(struct net_device *
+@@ -10611,7 +10672,7 @@ static int tg3_ioctl(struct net_device *
                        return -EAGAIN;
  
                spin_lock_bh(&tp->lock);
                spin_unlock_bh(&tp->lock);
  
                return err;
-@@ -11255,6 +11316,12 @@ static void __devinit tg3_get_5717_nvram
+@@ -11256,6 +11317,12 @@ static void __devinit tg3_get_5717_nvram
  /* Chips other than 5700/5701 use the NVRAM for fetching info. */
  static void __devinit tg3_nvram_init(struct tg3 *tp)
  {
        tw32_f(GRC_EEPROM_ADDR,
             (EEPROM_ADDR_FSM_RESET |
              (EEPROM_DEFAULT_CLOCK_PERIOD <<
-@@ -11515,6 +11582,9 @@ static int tg3_nvram_write_block(struct 
+@@ -11516,6 +11583,9 @@ static int tg3_nvram_write_block(struct
  {
        int ret;
  
        if (tp->tg3_flags & TG3_FLAG_EEPROM_WRITE_PROT) {
                tw32_f(GRC_LOCAL_CTRL, tp->grc_local_ctrl &
                       ~GRC_LCLCTRL_GPIO_OUTPUT1);
-@@ -12800,6 +12870,11 @@ static int __devinit tg3_get_invariants(
+@@ -12801,6 +12871,11 @@ static int __devinit tg3_get_invariants(
              GET_ASIC_REV(tp->pci_chip_rev_id) == ASIC_REV_5701)))
                tp->tg3_flags |= TG3_FLAG_SRAM_USE_CONFIG;
  
        /* Get eeprom hw config before calling tg3_set_power_state().
         * In particular, the TG3_FLG2_IS_NIC flag must be
         * determined before calling tg3_set_power_state() so that
-@@ -13189,6 +13264,10 @@ static int __devinit tg3_get_device_addr
+@@ -13190,6 +13265,10 @@ static int __devinit tg3_get_device_addr
        }
  
        if (!is_valid_ether_addr(&dev->dev_addr[0])) {
  #ifdef CONFIG_SPARC
                if (!tg3_get_default_macaddr_sparc(tp))
                        return 0;
-@@ -13681,6 +13760,7 @@ static char * __devinit tg3_phy_string(s
+@@ -13682,6 +13761,7 @@ static char * __devinit tg3_phy_string(s
        case PHY_ID_BCM5704:    return "5704";
        case PHY_ID_BCM5705:    return "5705";
        case PHY_ID_BCM5750:    return "5750";
        case PHY_ID_BCM5752:    return "5752";
        case PHY_ID_BCM5714:    return "5714";
        case PHY_ID_BCM5780:    return "5780";
-@@ -13892,6 +13972,13 @@ static int __devinit tg3_init_one(struct
+@@ -13893,6 +13973,13 @@ static int __devinit tg3_init_one(struct
                tp->msg_enable = tg3_debug;
        else
                tp->msg_enable = TG3_DEF_MSG_ENABLE;
index 2cfa824..a2afd5f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/b44.c
 +++ b/drivers/net/b44.c
-@@ -850,7 +850,7 @@ static int b44_rx(struct b44 *bp, int bu
+@@ -817,7 +817,7 @@ static int b44_rx(struct b44 *bp, int bu
                        struct sk_buff *copy_skb;
  
                        b44_recycle_rx(bp, cons, bp->rx_prod);
index 688d3e1..1720c73 100644 (file)
@@ -41,7 +41,7 @@
        UASM_i_LA_mostly(p, ptr, pgdc);
  #endif
        uasm_i_mfc0(p, tmp, C0_BADVADDR); /* get faulting address */
-@@ -733,12 +736,12 @@ static void __cpuinit build_r4000_tlb_re
+@@ -738,12 +741,12 @@ static void __cpuinit build_r4000_tlb_re
                /* No need for uasm_i_nop */
        }
  
@@ -57,7 +57,7 @@
        build_get_pgde32(&p, K0, K1); /* get pgd in K1 */
  #endif
  
-@@ -750,6 +753,9 @@ static void __cpuinit build_r4000_tlb_re
+@@ -755,6 +758,9 @@ static void __cpuinit build_r4000_tlb_re
        build_update_entries(&p, K0, K1);
        build_tlb_write_entry(&p, &l, &r, tlb_random);
        uasm_l_leave(&l, p);
@@ -67,7 +67,7 @@
        uasm_i_eret(&p); /* return from trap */
  
  #ifdef CONFIG_HUGETLB_PAGE
-@@ -1188,12 +1194,12 @@ build_r4000_tlbchange_handler_head(u32 *
+@@ -1193,12 +1199,12 @@ build_r4000_tlbchange_handler_head(u32 *
                                   struct uasm_reloc **r, unsigned int pte,
                                   unsigned int ptr)
  {
@@ -83,7 +83,7 @@
        build_get_pgde32(p, pte, ptr); /* get pgd in ptr */
  #endif
  
-@@ -1230,6 +1236,9 @@ build_r4000_tlbchange_handler_tail(u32 *
+@@ -1235,6 +1241,9 @@ build_r4000_tlbchange_handler_tail(u32 *
        build_update_entries(p, tmp, ptr);
        build_tlb_write_entry(p, l, r, tlb_indexed);
        uasm_l_leave(l, *p);
index 94ee4c5..fbbd577 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=2.6.32.16
+LINUX_VERSION:=2.6.32.25
 
 include $(INCLUDE_DIR)/target.mk
 
index 53655e3..0e7a845 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cobalt Microservers
 FEATURES:=targz pci ext2
 CFLAGS:=-O2 -pipe -mtune=r5000 -funit-at-a-time
 
-LINUX_VERSION:=2.6.32.16
+LINUX_VERSION:=2.6.32.25
 
 include $(INCLUDE_DIR)/target.mk
 
index e1e9f73..a3511d7 100644 (file)
@@ -71,7 +71,7 @@ Signed-off-by: Florian Fainelli <florian@openwrt.org>
  /* Control registers */
  
  #define FPCREG_RID    0       /* $0  = revision id */
-@@ -1274,6 +1276,13 @@ int fpu_emulator_cop1Handler(struct pt_r
+@@ -1281,6 +1283,13 @@ int fpu_emulator_cop1Handler(struct pt_r
  
        return sig;
  }
index 2854428..7572e6f 100644 (file)
@@ -23,7 +23,7 @@
  /* The Mellanox Tavor device gives false positive parity errors
   * Mark this device with a broken_parity_status, to allow
   * PCI scanning code to "skip" this now blacklisted device.
-@@ -1887,7 +1888,9 @@ static void __devinit fixup_rev1_53c810(
+@@ -1907,7 +1908,9 @@ static void __devinit fixup_rev1_53c810(
        }
  }
  DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_NCR, PCI_DEVICE_ID_NCR_53C810, fixup_rev1_53c810);
@@ -33,7 +33,7 @@
  /* Enable 1k I/O space granularity on the Intel P64H2 */
  static void __devinit quirk_p64h2_1k_io(struct pci_dev *dev)
  {
-@@ -2522,6 +2525,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
+@@ -2546,6 +2549,7 @@ DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_I
  DECLARE_PCI_FIXUP_HEADER(PCI_VENDOR_ID_INTEL, 0x1518, quirk_i82576_sriov);
  
  #endif        /* CONFIG_PCI_IOV */
index 9540ce0..8a6cf3e 100644 (file)
                        dev_queue_xmit_nit(skb, dev);
  
                if (netif_needs_gso(dev, skb)) {
-@@ -1789,8 +1796,7 @@ u16 skb_tx_hash(const struct net_device 
+@@ -1789,8 +1796,7 @@ u16 skb_tx_hash(const struct net_device
  }
  EXPORT_SYMBOL(skb_tx_hash);
  
        new->csum               = old->csum;
        new->local_df           = old->local_df;
        new->pkt_type           = old->pkt_type;
-@@ -2776,6 +2879,13 @@ void __init skb_init(void)
+@@ -2781,6 +2884,13 @@ void __init skb_init(void)
                                                0,
                                                SLAB_HWCACHE_ALIGN|SLAB_PANIC,
                                                NULL);
  /* return EBUSY when somebody else is registered, return EEXIST if the
   * same handler is registered, return 0 in case of success. */
  int nf_register_queue_handler(u_int8_t pf, const struct nf_queue_handler *qh)
-@@ -80,7 +100,7 @@ void nf_unregister_queue_handlers(const 
+@@ -80,7 +100,7 @@ void nf_unregister_queue_handlers(const
  }
  EXPORT_SYMBOL_GPL(nf_unregister_queue_handlers);
  
index 0808c77..b689fa6 100644 (file)
@@ -22,7 +22,7 @@
  struct tcrypt_result {
        struct completion completion;
        int err;
-@@ -2350,8 +2352,11 @@ static int alg_find_test(const char *alg
+@@ -2434,8 +2436,11 @@ static int alg_find_test(const char *alg
        return -1;
  }
  
@@ -34,7 +34,7 @@
        int i;
        int j;
        int rc;
-@@ -2406,5 +2411,8 @@ notest:
+@@ -2490,5 +2495,8 @@ notest:
        return 0;
  non_fips_alg:
        return -EINVAL;
index f48c580..def9609 100644 (file)
@@ -1,15 +1,6 @@
 --- a/drivers/ssb/driver_chipcommon.c
 +++ b/drivers/ssb/driver_chipcommon.c
-@@ -233,6 +233,8 @@ void ssb_chipcommon_init(struct ssb_chip
- {
-       if (!cc->dev)
-               return; /* We don't have a ChipCommon */
-+      if (cc->dev->id.revision >= 11)
-+              cc->status = chipco_read32(cc, SSB_CHIPCO_CHIPSTAT);
-       ssb_pmu_init(cc);
-       chipco_powercontrol_init(cc);
-       ssb_chipco_set_clockmode(cc, SSB_CLKMODE_FAST);
-@@ -370,6 +372,7 @@ u32 ssb_chipco_gpio_control(struct ssb_c
+@@ -373,6 +373,7 @@ u32 ssb_chipco_gpio_control(struct ssb_c
  {
        return chipco_write32_masked(cc, SSB_CHIPCO_GPIOCTL, mask, value);
  }
  }
  
  /* Get the word-offset for a SSB_SPROM_XXX define. */
--#define SPOFF(offset) (((offset) - SSB_SPROM_BASE) / sizeof(u16))
+-#define SPOFF(offset) (((offset) - SSB_SPROM_BASE1) / sizeof(u16))
 +#define SPOFF(offset) ((offset) / sizeof(u16))
  /* Helper to extract some _offset, which is one of the SSB_SPROM_XXX defines. */
  #define SPEX16(_outvar, _offset, _mask, _shift)       \
        out->_outvar = ((in[SPOFF(_offset)] & (_mask)) >> (_shift))
-@@ -253,7 +254,7 @@ static int sprom_do_read(struct ssb_bus 
-       int i;
-       for (i = 0; i < bus->sprom_size; i++)
--              sprom[i] = ioread16(bus->mmio + SSB_SPROM_BASE + (i * 2));
-+              sprom[i] = ioread16(bus->mmio + bus->sprom_offset + (i * 2));
-       return 0;
- }
-@@ -284,7 +285,7 @@ static int sprom_do_write(struct ssb_bus
-                       ssb_printk("75%%");
-               else if (i % 2)
-                       ssb_printk(".");
--              writew(sprom[i], bus->mmio + SSB_SPROM_BASE + (i * 2));
-+              writew(sprom[i], bus->mmio + bus->sprom_offset + (i * 2));
-               mmiowb();
-               msleep(20);
-       }
-@@ -620,6 +621,14 @@ static int ssb_pci_sprom_get(struct ssb_
-       int err = -ENOMEM;
-       u16 *buf;
-+      if (!ssb_is_sprom_available(bus)) {
-+              ssb_printk(KERN_ERR PFX "No SPROM available!\n");
-+              return -ENODEV;
-+      }
-+
-+      bus->sprom_offset = (bus->chipco.dev->id.revision < 31) ?
-+              SSB_SPROM_BASE1 : SSB_SPROM_BASE31;
-+
-       buf = kcalloc(SSB_SPROMSIZE_WORDS_R123, sizeof(u16), GFP_KERNEL);
-       if (!buf)
-               goto out;
 --- a/drivers/ssb/pcihost_wrapper.c
 +++ b/drivers/ssb/pcihost_wrapper.c
 @@ -12,6 +12,7 @@
 +static int ssb_pcmcia_get_mac(struct pcmcia_device *p_dev,
 +                      tuple_t *tuple,
 +                      void *priv)
-+{
+ {
+-      tuple_t tuple;
+-      int res;
+-      unsigned char buf[32];
 +      struct ssb_sprom *sprom = priv;
 +
 +      if (tuple->TupleData[0] != CISTPL_FUNCE_LAN_NODE_ID)
 +static int ssb_pcmcia_do_get_invariants(struct pcmcia_device *p_dev,
 +                                      tuple_t *tuple,
 +                                      void *priv)
- {
--      tuple_t tuple;
--      int res;
--      unsigned char buf[32];
++{
 +      struct ssb_init_invariants *iv = priv;
        struct ssb_sprom *sprom = &iv->sprom;
        struct ssb_boardinfo *bi = &iv->boardinfo;
        if (err)
                ssb_printk(KERN_ERR PFX "SPROM write: Could not thaw all devices\n");
  out_unlock:
-@@ -179,3 +176,17 @@ const struct ssb_sprom *ssb_get_fallback
- {
-       return fallback_sprom;
- }
-+
-+/* http://bcm-v4.sipsolutions.net/802.11/IsSpromAvailable */
-+bool ssb_is_sprom_available(struct ssb_bus *bus)
-+{
-+      /* status register only exists on chipcomon rev >= 11 and we need check
-+         for >= 31 only */
-+      /* this routine differs from specs as we do not access SPROM directly
-+         on PCMCIA */
-+      if (bus->bustype == SSB_BUSTYPE_PCI &&
-+          bus->chipco.dev->id.revision >= 31)
-+              return bus->chipco.capabilities & SSB_CHIPCO_CAP_SPROM;
-+
-+      return true;
-+}
 --- a/drivers/ssb/ssb_private.h
 +++ b/drivers/ssb/ssb_private.h
 @@ -176,19 +176,27 @@ extern const struct ssb_sprom *ssb_get_f
  
        /* See enum ssb_quirks */
        unsigned int quirks;
-@@ -301,6 +305,7 @@ struct ssb_bus {
-       /* ID information about the Chip. */
-       u16 chip_id;
-       u16 chip_rev;
-+      u16 sprom_offset;
-       u16 sprom_size;         /* number of words in sprom */
-       u8 chip_package;
-@@ -390,6 +395,9 @@ extern int ssb_bus_sdiobus_register(stru
- extern void ssb_bus_unregister(struct ssb_bus *bus);
-+/* Does the device have an SPROM? */
-+extern bool ssb_is_sprom_available(struct ssb_bus *bus);
-+
- /* Set a fallback SPROM.
-  * See kdoc at the function definition for complete documentation. */
- extern int ssb_arch_set_fallback_sprom(const struct ssb_sprom *sprom);
---- a/include/linux/ssb/ssb_driver_chipcommon.h
-+++ b/include/linux/ssb/ssb_driver_chipcommon.h
-@@ -53,6 +53,7 @@
- #define  SSB_CHIPCO_CAP_64BIT         0x08000000      /* 64-bit Backplane */
- #define  SSB_CHIPCO_CAP_PMU           0x10000000      /* PMU available (rev >= 20) */
- #define  SSB_CHIPCO_CAP_ECI           0x20000000      /* ECI available (rev >= 20) */
-+#define  SSB_CHIPCO_CAP_SPROM         0x40000000      /* SPROM present */
- #define SSB_CHIPCO_CORECTL            0x0008
- #define  SSB_CHIPCO_CORECTL_UARTCLK0  0x00000001      /* Drive UART with internal clock */
- #define        SSB_CHIPCO_CORECTL_SE          0x00000002      /* sync clk out enable (corerev >= 3) */
-@@ -385,6 +386,7 @@
- /** Chip specific Chip-Status register contents. */
-+#define SSB_CHIPCO_CHST_4322_SPROM_EXISTS     0x00000040 /* SPROM present */
- #define SSB_CHIPCO_CHST_4325_SPROM_OTP_SEL    0x00000003
- #define SSB_CHIPCO_CHST_4325_DEFCIS_SEL               0 /* OTP is powered up, use def. CIS, no SPROM */
- #define SSB_CHIPCO_CHST_4325_SPROM_SEL                1 /* OTP is powered up, SPROM is present */
-@@ -398,6 +400,18 @@
- #define SSB_CHIPCO_CHST_4325_RCAL_VALUE_SHIFT 4
- #define SSB_CHIPCO_CHST_4325_PMUTOP_2B                0x00000200 /* 1 for 2b, 0 for to 2a */
-+/** Macros to determine SPROM presence based on Chip-Status register. */
-+#define SSB_CHIPCO_CHST_4312_SPROM_PRESENT(status) \
-+      ((status & SSB_CHIPCO_CHST_4325_SPROM_OTP_SEL) != \
-+              SSB_CHIPCO_CHST_4325_OTP_SEL)
-+#define SSB_CHIPCO_CHST_4322_SPROM_PRESENT(status) \
-+      (status & SSB_CHIPCO_CHST_4322_SPROM_EXISTS)
-+#define SSB_CHIPCO_CHST_4325_SPROM_PRESENT(status) \
-+      (((status & SSB_CHIPCO_CHST_4325_SPROM_OTP_SEL) != \
-+              SSB_CHIPCO_CHST_4325_DEFCIS_SEL) && \
-+       ((status & SSB_CHIPCO_CHST_4325_SPROM_OTP_SEL) != \
-+              SSB_CHIPCO_CHST_4325_OTP_SEL))
-+
- /** Clockcontrol masks and values **/
-@@ -564,6 +578,7 @@ struct ssb_chipcommon_pmu {
- struct ssb_chipcommon {
-       struct ssb_device *dev;
-       u32 capabilities;
-+      u32 status;
-       /* Fast Powerup Delay constant */
-       u16 fast_pwrup_delay;
-       struct ssb_chipcommon_pmu pmu;
 --- a/include/linux/ssb/ssb_regs.h
 +++ b/include/linux/ssb/ssb_regs.h
-@@ -170,26 +170,27 @@
- #define SSB_SPROMSIZE_WORDS_R4                220
- #define SSB_SPROMSIZE_BYTES_R123      (SSB_SPROMSIZE_WORDS_R123 * sizeof(u16))
+@@ -172,25 +172,25 @@
  #define SSB_SPROMSIZE_BYTES_R4                (SSB_SPROMSIZE_WORDS_R4 * sizeof(u16))
--#define SSB_SPROM_BASE                        0x1000
+ #define SSB_SPROM_BASE1                       0x1000
+ #define SSB_SPROM_BASE31              0x0800
 -#define SSB_SPROM_REVISION            0x107E
-+#define SSB_SPROM_BASE1                       0x1000
-+#define SSB_SPROM_BASE31              0x0800
 +#define SSB_SPROM_REVISION            0x007E
  #define  SSB_SPROM_REVISION_REV               0x00FF  /* SPROM Revision number */
  #define  SSB_SPROM_REVISION_CRC               0xFF00  /* SPROM CRC8 value */
  #define  SSB_SPROM1_BINF_BREV         0x00FF  /* Board Revision */
  #define  SSB_SPROM1_BINF_CCODE                0x0F00  /* Country Code */
  #define  SSB_SPROM1_BINF_CCODE_SHIFT  8
-@@ -197,63 +198,63 @@
+@@ -198,63 +198,63 @@
  #define  SSB_SPROM1_BINF_ANTBG_SHIFT  12
  #define  SSB_SPROM1_BINF_ANTA         0xC000  /* Available A-PHY antennas */
  #define  SSB_SPROM1_BINF_ANTA_SHIFT   14
  #define  SSB_SPROM3_CCKPO_1M          0x000F  /* 1M Rate PO */
  #define  SSB_SPROM3_CCKPO_2M          0x00F0  /* 2M Rate PO */
  #define  SSB_SPROM3_CCKPO_2M_SHIFT    4
-@@ -264,100 +265,100 @@
+@@ -265,100 +265,100 @@
  #define  SSB_SPROM3_OFDMGPO           0x107A  /* G-PHY OFDM Power Offset (4 bytes, BigEndian) */
  
  /* SPROM Revision 4 */
  #define  SSB_SPROM8_RSSISMF2G         0x000F
  #define  SSB_SPROM8_RSSISMC2G         0x00F0
  #define  SSB_SPROM8_RSSISMC2G_SHIFT   4
-@@ -365,7 +366,7 @@
+@@ -366,7 +366,7 @@
  #define  SSB_SPROM8_RSSISAV2G_SHIFT   8
  #define  SSB_SPROM8_BXA2G             0x1800
  #define  SSB_SPROM8_BXA2G_SHIFT               11
  #define  SSB_SPROM8_RSSISMF5G         0x000F
  #define  SSB_SPROM8_RSSISMC5G         0x00F0
  #define  SSB_SPROM8_RSSISMC5G_SHIFT   4
-@@ -373,47 +374,47 @@
+@@ -374,47 +374,47 @@
  #define  SSB_SPROM8_RSSISAV5G_SHIFT   8
  #define  SSB_SPROM8_BXA5G             0x1800
  #define  SSB_SPROM8_BXA5G_SHIFT               11
index b80eb25..5d55fa9 100644 (file)
@@ -68,7 +68,7 @@
   * macro override instead of weak attribute alias, to workaround
 --- a/kernel/sched.c
 +++ b/kernel/sched.c
-@@ -6113,6 +6113,7 @@ int can_nice(const struct task_struct *p
+@@ -6224,6 +6224,7 @@ int can_nice(const struct task_struct *p
        return (nice_rlim <= p->signal->rlim[RLIMIT_NICE].rlim_cur ||
                capable(CAP_SYS_NICE));
  }
@@ -86,7 +86,7 @@
  
  /**
   * zap_vma_ptes - remove ptes mapping the vma
-@@ -2486,6 +2487,7 @@ int vmtruncate_range(struct inode *inode
+@@ -2496,6 +2497,7 @@ int vmtruncate_range(struct inode *inode
  
        return 0;
  }
                                void *caller)
 --- a/include/linux/mm.h
 +++ b/include/linux/mm.h
-@@ -713,6 +713,7 @@ extern void show_free_areas(void);
+@@ -717,6 +717,7 @@ extern void show_free_areas(void);
  
  int shmem_lock(struct file *file, int lock, struct user_struct *user);
  struct file *shmem_file_setup(const char *name, loff_t size, unsigned long flags);
index f65dc91..cf4173b 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Intel IXP4xx
 FEATURES:=squashfs
 SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=2.6.32.16
+LINUX_VERSION:=2.6.32.25
 
 include $(INCLUDE_DIR)/target.mk
 
index 84845d3..63a23ee 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 SUBTARGETS=generic harddisk
 CFLAGS=-Os -pipe -march=armv5t -mtune=xscale -funit-at-a-time
 
-LINUX_VERSION:=2.6.32.16
+LINUX_VERSION:=2.6.32.25
 
 include $(INCLUDE_DIR)/target.mk
 
index 29d7f0d..2d0af94 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=AMCC/IBM PPC40x
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=405
 
-LINUX_VERSION:=2.6.32.16
+LINUX_VERSION:=2.6.32.25
 
 include $(INCLUDE_DIR)/target.mk
 
index bd8157a..599a1d1 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=AMCC/IBM PPC44x
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=440
 
-LINUX_VERSION:=2.6.32.16
+LINUX_VERSION:=2.6.32.25
 
 include $(INCLUDE_DIR)/target.mk
 
index f400b77..3a2afbe 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci targz
 
-LINUX_VERSION:=2.6.32.16
+LINUX_VERSION:=2.6.32.25
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
index 9a7ea84..7da783d 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=x86
 FEATURES:=squashfs jffs2 ext2 vdi vmdk pcmcia targz
 SUBTARGETS=generic olpc xen_domu ep80579
 
-LINUX_VERSION:=2.6.32.16
+LINUX_VERSION:=2.6.32.25
 
 include $(INCLUDE_DIR)/target.mk
 
index c94d68c..aa5ca53 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
 FEATURES:=jffs2 targz ubifs audio
 SUBTARGETS:=qi_lb60 n516 n526
 
-LINUX_VERSION:=2.6.32.16
+LINUX_VERSION:=2.6.32.25
 
 DEVICE_TYPE=other