[packages_10.03.2] keepalived: merge r28920
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 15:19:56 +0000 (15:19 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 15:19:56 +0000 (15:19 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_10.03.2@30211 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/keepalived/Makefile
net/keepalived/files/keepalived.init

index 4ff0673..d7396b2 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=keepalived
 PKG_VERSION:=1.1.19
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= http://www.keepalived.org/software
index 723947c..2807f92 100644 (file)
@@ -1,13 +1,14 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 
 START=70
 
+SERVICE_USE_PID=1
+
 start() {
-        [ -f /etc/keepalived/keepalived.conf ] && /usr/sbin/keepalived
+       service_start /usr/sbin/keepalived
 }
 
 stop() {
-        killall keepalived      
+       service_stop /usr/sbin/keepalived
 }
-