dsniff: uClibc-0.9.31 fix
authormb <mb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 3 Nov 2010 22:45:51 +0000 (22:45 +0000)
committermb <mb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 3 Nov 2010 22:45:51 +0000 (22:45 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@23845 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/dsniff/patches/003-gdbm.patch
net/dsniff/patches/004-no_yp.patch
net/dsniff/patches/006-pcap_header.patch
net/dsniff/patches/008-md5_include.patch
net/dsniff/patches/010-clk-tck-fix.patch [new file with mode: 0644]

index 30190ab..67be3e5 100644 (file)
@@ -1,6 +1,7 @@
-diff -Nur dsniff-2.3/configure dsniff-2.3.patched/configure
---- dsniff-2.3/configure       2005-06-11 18:13:59.000000000 +0200
-+++ dsniff-2.3.patched/configure       2005-06-11 18:14:37.000000000 +0200
+Index: dsniff-2.4/configure
+===================================================================
+--- dsniff-2.4.orig/configure  2010-11-03 23:42:49.466000001 +0100
++++ dsniff-2.4/configure       2010-11-03 23:42:52.921000006 +0100
 @@ -16,6 +16,8 @@
  ac_help="$ac_help
    --with-db=DIR           use Berkeley DB (with --enable-compat185) in DIR"
@@ -10,7 +11,7 @@ diff -Nur dsniff-2.3/configure dsniff-2.3.patched/configure
    --with-libpcap=DIR      use libpcap in DIR"
  ac_help="$ac_help
    --with-libnet=DIR       use libnet in DIR"
-@@ -3051,7 +3053,40 @@
+@@ -3059,7 +3061,40 @@
  
  fi
  
@@ -51,10 +52,11 @@ diff -Nur dsniff-2.3/configure dsniff-2.3.patched/configure
  
  
  echo $ac_n "checking for libnet""... $ac_c" 1>&6
-diff -Nur dsniff-2.3/record.c dsniff-2.3.patched/record.c
---- dsniff-2.3/record.c        2000-11-14 16:51:02.000000000 +0100
-+++ dsniff-2.3.patched/record.c        2005-06-11 18:14:56.000000000 +0200
-@@ -13,12 +13,7 @@
+Index: dsniff-2.4/record.c
+===================================================================
+--- dsniff-2.4.orig/record.c   2010-11-03 23:42:49.471000001 +0100
++++ dsniff-2.4/record.c        2010-11-03 23:42:52.922000005 +0100
+@@ -15,12 +15,7 @@
  #include <stdio.h>
  #include <time.h>
  #include <md5.h>
@@ -66,9 +68,9 @@ diff -Nur dsniff-2.3/record.c dsniff-2.3.patched/record.c
 -#endif
 +#include <gdbm.h>
  #include <libnet.h>
  #include "options.h"
- #include "record.h"
-@@ -34,7 +29,7 @@
+@@ -37,7 +32,7 @@
        struct netobj   data;
  };
        
@@ -77,7 +79,7 @@ diff -Nur dsniff-2.3/record.c dsniff-2.3.patched/record.c
  
  static int
  xdr_rec(XDR *xdrs, struct rec *rec)
-@@ -61,7 +56,6 @@
+@@ -64,7 +59,6 @@
        
        tm = localtime(&rec->time);
        strftime(tstr, sizeof(tstr), "%x %X", tm);
@@ -85,7 +87,7 @@ diff -Nur dsniff-2.3/record.c dsniff-2.3.patched/record.c
        srcp = libnet_host_lookup(rec->src, Opt_dns);
        dstp = libnet_host_lookup(rec->dst, Opt_dns);
  
-@@ -86,10 +80,10 @@
+@@ -89,10 +83,10 @@
        fflush(stdout);
  }
  
@@ -98,7 +100,7 @@ diff -Nur dsniff-2.3/record.c dsniff-2.3.patched/record.c
        static u_char hash[16];
        MD5_CTX ctx;
  
-@@ -102,16 +96,16 @@
+@@ -105,16 +99,16 @@
        MD5Update(&ctx, rec->data.n_bytes, rec->data.n_len);
        MD5Final(hash, &ctx);
  
@@ -119,7 +121,7 @@ diff -Nur dsniff-2.3/record.c dsniff-2.3.patched/record.c
        XDR xdrs;
        u_char buf[2048];
        
-@@ -120,15 +114,15 @@
+@@ -123,15 +117,15 @@
        if (!xdr_rec(&xdrs, rec))
                return (0);
        
@@ -139,7 +141,7 @@ diff -Nur dsniff-2.3/record.c dsniff-2.3.patched/record.c
        
        return (1);
  }
-@@ -136,18 +130,22 @@
+@@ -139,18 +133,22 @@
  void
  record_dump(void)
  {
@@ -166,7 +168,7 @@ diff -Nur dsniff-2.3/record.c dsniff-2.3.patched/record.c
        }
  }
  
-@@ -155,16 +153,23 @@
+@@ -158,16 +156,23 @@
  record_init(char *file)
  {
        int flags, mode;
@@ -194,7 +196,7 @@ diff -Nur dsniff-2.3/record.c dsniff-2.3.patched/record.c
                return (0);
  
        return (1);
-@@ -203,6 +208,6 @@
+@@ -206,6 +211,6 @@
  void
  record_close(void)
  {
index 48393e2..774e04e 100644 (file)
@@ -1,7 +1,8 @@
-diff -Nur dsniff-2.3/decode.c dsniff-2.3.patched/decode.c
---- dsniff-2.3/decode.c        2000-12-15 21:03:26.000000000 +0100
-+++ dsniff-2.3.patched/decode.c        2005-06-11 18:17:48.000000000 +0200
-@@ -49,8 +49,6 @@
+Index: dsniff-2.4/decode.c
+===================================================================
+--- dsniff-2.4.orig/decode.c   2010-11-03 23:42:49.419000001 +0100
++++ dsniff-2.4/decode.c        2010-11-03 23:42:56.481000002 +0100
+@@ -51,8 +51,6 @@
  extern int decode_portmap(u_char *, int, u_char *, int);
  extern int decode_mountd(u_char *, int, u_char *, int);
  extern int decode_vrrp(u_char *, int, u_char *, int);
@@ -10,7 +11,7 @@ diff -Nur dsniff-2.3/decode.c dsniff-2.3.patched/decode.c
  
  static struct decode decodes[] = {
        { "hex",        decode_hex },
-@@ -86,8 +84,6 @@
+@@ -88,8 +86,6 @@
        { "irc",        decode_irc },
        { "portmap",    decode_portmap },
        { "mountd",     decode_mountd },
@@ -19,18 +20,20 @@ diff -Nur dsniff-2.3/decode.c dsniff-2.3.patched/decode.c
        { NULL }
  };
  
-diff -Nur dsniff-2.3/dsniff.services dsniff-2.3.patched/dsniff.services
---- dsniff-2.3/dsniff.services 2000-12-15 21:10:58.000000000 +0100
-+++ dsniff-2.3.patched/dsniff.services 2005-06-11 18:19:27.000000000 +0200
+Index: dsniff-2.4/dsniff.services
+===================================================================
+--- dsniff-2.4.orig/dsniff.services    2010-11-03 23:42:49.429000001 +0100
++++ dsniff-2.4/dsniff.services 2010-11-03 23:42:56.481000002 +0100
 @@ -66,5 +66,3 @@
  aim           9898/tcp
  pcanywhere    65301/tcp
  mountd                100005/rpc
 -ypserv                100004/rpc
 -yppasswd      100009/rpc
-diff -Nur dsniff-2.3/Makefile.in dsniff-2.3.patched/Makefile.in
---- dsniff-2.3/Makefile.in     2005-06-11 18:17:20.000000000 +0200
-+++ dsniff-2.3.patched/Makefile.in     2005-06-11 18:17:48.000000000 +0200
+Index: dsniff-2.4/Makefile.in
+===================================================================
+--- dsniff-2.4.orig/Makefile.in        2010-11-03 23:42:51.736998874 +0100
++++ dsniff-2.4/Makefile.in     2010-11-03 23:42:56.481000002 +0100
 @@ -60,7 +60,7 @@
          decode_pop.c decode_portmap.c decode_postgresql.c decode_pptp.c \
          decode_rip.c decode_rlogin.c decode_smb.c decode_smtp.c \
index 6be3bf2..6836557 100644 (file)
@@ -1,7 +1,8 @@
-diff -Nur dsniff-2.3/configure dsniff-2.3.patched/configure
---- dsniff-2.3/configure       2000-12-03 05:35:46.000000000 +0100
-+++ dsniff-2.3.patched/configure       2005-06-09 11:44:33.000000000 +0200
-@@ -3023,7 +3023,7 @@
+Index: dsniff-2.4/configure
+===================================================================
+--- dsniff-2.4.orig/configure  2010-11-03 23:42:52.921000006 +0100
++++ dsniff-2.4/configure       2010-11-03 23:43:00.504000001 +0100
+@@ -3033,7 +3033,7 @@
        PCAPINC="-I$withval -I$withval/bpf"
        PCAPLIB="-L$withval -lpcap"
       elif test -f $withval/include/pcap.h -a \
index ff71343..f8d3829 100644 (file)
@@ -1,12 +1,13 @@
-diff -ru dsniff-2.4/record.c dsniff-2.4-new/record.c\r
---- dsniff-2.4/record.c        2009-05-27 23:40:08.000000000 -0700\r
-+++ dsniff-2.4-new/record.c    2009-05-27 23:39:53.000000000 -0700\r
-@@ -14,7 +14,7 @@\r
\r
- #include <stdio.h>\r
- #include <time.h>\r
--#include <md5.h>\r
-+#include "missing/md5.h"\r
- #include <gdbm.h>\r
- #include <libnet.h>\r
\r
+Index: dsniff-2.4/record.c
+===================================================================
+--- dsniff-2.4.orig/record.c   2010-11-03 23:43:14.268000004 +0100
++++ dsniff-2.4/record.c        2010-11-03 23:43:16.947000004 +0100
+@@ -14,7 +14,7 @@
+ #include <stdio.h>
+ #include <time.h>
+-#include <md5.h>
++#include "missing/md5.h"
+ #include <gdbm.h>
+ #include <libnet.h>
diff --git a/net/dsniff/patches/010-clk-tck-fix.patch b/net/dsniff/patches/010-clk-tck-fix.patch
new file mode 100644 (file)
index 0000000..cc15bef
--- /dev/null
@@ -0,0 +1,15 @@
+Index: dsniff-2.4/sshow.c
+===================================================================
+--- dsniff-2.4.orig/sshow.c    2010-11-03 23:41:56.335999997 +0100
++++ dsniff-2.4/sshow.c 2010-11-03 23:42:10.981000001 +0100
+@@ -42,6 +42,10 @@
+ #define HISTORY_SIZE                  16
++#ifndef CLK_TCK
++# define CLK_TCK      CLOCKS_PER_SEC
++#endif
++
+ typedef struct {
+       u_int min, max;
+ } range;