[packages] grep: simplify package remove
authortripolar <tripolar@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 26 Oct 2013 16:09:40 +0000 (16:09 +0000)
committertripolar <tripolar@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 26 Oct 2013 16:09:40 +0000 (16:09 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@38543 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/grep/Makefile

index b6725c0..6e648e0 100644 (file)
@@ -44,14 +44,7 @@ endef
 
 define Package/grep/prerm
 $${IPKG_INSTROOT}/bin/busybox grep -h 2>&1 | grep -q BusyBox && \
-touch $${IPKG_INSTROOT}/tmp/bb_with_grep
-endef
-
-define Package/grep/postrm
-#!/bin/sh
-[ -f $${IPKG_INSTROOT}/tmp/bb_with_grep ] && \
-ln -sf busybox $${IPKG_INSTROOT}/bin/grep && \
-rm $${IPKG_INSTROOT}/tmp/bb_with_grep
+ln -sf busybox $${IPKG_INSTROOT}/bin/grep
 exit 0
 endef