added imlib2
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 9 Oct 2007 22:08:44 +0000 (22:08 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 9 Oct 2007 22:08:44 +0000 (22:08 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@9229 3c298f89-4303-0410-b956-a3cf2f4a3e73

XOrg/lib/imlib2/Makefile [new file with mode: 0644]

diff --git a/XOrg/lib/imlib2/Makefile b/XOrg/lib/imlib2/Makefile
new file mode 100644 (file)
index 0000000..eae8f84
--- /dev/null
@@ -0,0 +1,64 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# blogic@openwrt.org
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=imlib2
+PKG_VERSION:=1.2.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://downloads.sourceforge.net/enlightenment/
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/imlib2
+  SECTION:=xorg-libraries
+  CATEGORY:=Xorg
+  SUBMENU:=libraries
+  TITLE:=Image library
+  DEPENDS:=+xorg-server-essentials +giflib +libtiff +libjpeg +gtk-1.2.10 +libnotimpl +libfreetype
+endef
+
+CONFIGURE_ARGS+=--disable-gtktest LIBS="-Wl,-rpath-link=$(STAGING_DIR)/usr/lib"
+
+EXTRA_LDFLAGS+=-lnotimpl
+
+define Build/Configure
+       (cd $(PKG_BUILD_DIR)/$(CONFIGURE_PATH); \
+               if [ -x $(CONFIGURE_CMD) ]; then \
+                       $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/ && \
+                       $(CONFIGURE_VARS) \
+                       $(CONFIGURE_CMD) \
+                       $(CONFIGURE_ARGS_XTRA) \
+                       $(CONFIGURE_ARGS) ;\
+               fi \
+       )
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) install DESTDIR=$(PKG_INSTALL_DIR)
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/
+       $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+       $(SED)  "s,"libdir\=\'/usr/lib\'",libdir='$(1)/usr/lib\'," $(1)/usr/lib/libImlib2.la
+       $(SED)  "s,prefix.*,prefix=$(STAGING_DIR)/usr,g" $(1)/usr/bin/imlib2-config 
+       $(SED)  "s,exec_prefix.*,exec_prefix=$(STAGING_DIR)/usr,g" $(1)/usr/bin/imlib2-config
+       $(CP) $(PKG_BUILD_DIR)/src/modules/loaders/.libs/*.so $(1)/usr/lib/imlib2/loaders/
+endef
+
+define Package/imlib2/install
+       $(INSTALL_DIR) $(1)/usr/lib/imlib2/loaders/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib*so* $(1)/usr/lib/
+       $(CP) $(PKG_BUILD_DIR)/src/modules/loaders/.libs/*.so $(1)/usr/lib/imlib2/loaders/
+endef
+
+$(eval $(call BuildPackage,imlib2))