[packages] dbus: fix segfault caused by -pie, remove flag and bump pkg revsion -...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 5 Aug 2009 22:20:49 +0000 (22:20 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 5 Aug 2009 22:20:49 +0000 (22:20 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@17137 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/dbus/Makefile
utils/dbus/patches/01-dbus-nopie-fix.patch [new file with mode: 0644]

index 2afb9c6..419d5ac 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 # Make sure to also update the dbus-x package
 PKG_NAME:=dbus
 PKG_VERSION:=1.2.4.6permissive
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://dbus.freedesktop.org/releases/dbus/
diff --git a/utils/dbus/patches/01-dbus-nopie-fix.patch b/utils/dbus/patches/01-dbus-nopie-fix.patch
new file mode 100644 (file)
index 0000000..36dfbf9
--- /dev/null
@@ -0,0 +1,23 @@
+diff -ruN dbus-1.2.4.6permissive.orig/configure dbus-1.2.4.6permissive/configure
+--- dbus-1.2.4.6permissive.orig/configure      2009-05-06 13:35:38.000000000 -0400
++++ dbus-1.2.4.6permissive/configure   2009-08-05 17:53:25.000000000 -0400
+@@ -20927,19 +20927,6 @@
+      ;;
+   esac
+
+-  case " $CFLAGS " in
+-  *[\ \       ]-fPIE[\ \      ]*) ;;
+-  *) if cc_supports_flag -fPIE; then
+-        PIE_CFLAGS="-fPIE"
+-        if ld_supports_flag -z,relro; then
+-           PIE_LDFLAGS="-pie -Wl,-z,relro"
+-        else
+-           PIE_LDFLAGS="-pie"
+-        fi
+-     fi
+-     ;;
+-  esac
+-
+   ### Disabled warnings, and compiler flag overrides
+
+   # Let's just ignore unused for now