collectd: remove bogus maximum of 3600 seconds for 'timeleft'
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 21 Dec 2012 18:25:38 +0000 (18:25 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 21 Dec 2012 18:25:38 +0000 (18:25 +0000)
The apcups and snmp plugins were using this to store time in minutes, but
nut uses seconds. Upstream wants to make them all use seconds (unlike my
first patch to make nut use minutes to be consistent with the others), so
all we need to do is fix the maximum. If we were *using* the apcups and
snmp plugins, those would probably want fixing to multiply by 60.

Signed-off-by: David Woodhouse <David.Woodhouse@intel.com>
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@34831 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/collectd/Makefile
utils/collectd/patches/130-timeleft-max.patch [new file with mode: 0644]

index 6e609b0..d923ab4 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=collectd
 PKG_VERSION:=4.10.8
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://collectd.org/files/
diff --git a/utils/collectd/patches/130-timeleft-max.patch b/utils/collectd/patches/130-timeleft-max.patch
new file mode 100644 (file)
index 0000000..f263152
--- /dev/null
@@ -0,0 +1,14 @@
+Derived from uptream commit d5b09f2b: http://octo.cx/d5b09f2
+
+--- a/src/types.db
++++ b/src/types.db
+@@ -152,7 +152,7 @@ tcp_connections            value:GAUGE:0:429496729
+ temperature           value:GAUGE:-273.15:U
+ threads                       value:GAUGE:0:U
+ time_dispersion               seconds:GAUGE:-1000000:1000000
+-timeleft              timeleft:GAUGE:0:3600
++timeleft              timeleft:GAUGE:0:U
+ time_offset           seconds:GAUGE:-1000000:1000000
+ total_bytes           value:DERIVE:0:U
+ total_requests                value:DERIVE:0:U
+