libffi: split build and source directory to work around some makefile bugs
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 6 Jul 2012 09:23:05 +0000 (09:23 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 6 Jul 2012 09:23:05 +0000 (09:23 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@32632 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/libffi/Makefile

index 65668d2..e6bd7a6 100644 (file)
@@ -40,6 +40,15 @@ A layer must exist above libffi that handles type conversions for values passed
 between the two languages.
 endef
 
+CONFIGURE_PATH = build
+CONFIGURE_CMD = ../configure
+MAKE_PATH = build
+
+define Build/Configure
+       mkdir -p $(PKG_BUILD_DIR)/build
+       $(Build/Configure/Default)
+endef
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) \