fix "d" mess in batman adv package
authormarek <marek@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Mar 2009 15:48:41 +0000 (15:48 +0000)
committermarek <marek@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Mar 2009 15:48:41 +0000 (15:48 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@14842 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/batman-advanced/Makefile
net/batman-advanced/files/etc/config/batman-adv-kernelland [new file with mode: 0644]
net/batman-advanced/files/etc/config/batman-adv-userspace [new file with mode: 0644]
net/batman-advanced/files/etc/config/batmand-adv-kernelland [deleted file]
net/batman-advanced/files/etc/config/batmand-adv-userspace [deleted file]
net/batman-advanced/files/etc/init.d/batman-adv-kernelland [new file with mode: 0644]
net/batman-advanced/files/etc/init.d/batman-adv-userspace [new file with mode: 0644]
net/batman-advanced/files/etc/init.d/batmand-adv-kernelland [deleted file]
net/batman-advanced/files/etc/init.d/batmand-adv-userspace [deleted file]

index 4c9ce88..194df05 100644 (file)
@@ -8,7 +8,7 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_NAME:=batmand-adv
+PKG_NAME:=batman-adv
 PKG_REV:=1220
 PKG_VERSION:=r$(PKG_REV)
 PKG_RELEASE:=1
@@ -34,7 +34,7 @@ define Package/batman-adv/Default
   MAINTAINER:=Marek Lindner <lindner_marek@yahoo.de>
 endef
 
-define Package/batmand-adv-userspace
+define Package/batman-adv-userspace
 $(call Package/batman-adv/Default)
   SECTION:=net
   CATEGORY:=Network
@@ -42,7 +42,7 @@ $(call Package/batman-adv/Default)
   TITLE:=B.A.T.M.A.N. layer 2 routing daemon
 endef
 
-define Package/batmand-adv-userspace/description
+define Package/batman-adv-userspace/description
 B.A.T.M.A.N. layer 2 routing daemon
 endef
 
@@ -106,7 +106,7 @@ MAKE_TOOL_ARGS += \
 define Build/Configure
 endef
 
-ifneq ($(CONFIG_PACKAGE_batmand-adv-userspace),n)
+ifneq ($(CONFIG_PACKAGE_batman-adv-userspace),n)
        BUILD_ADV = $(MAKE) -C $(PKG_BUILD_DIR)/batman-adv-userspace $(MAKE_ARGS)
 endif
 
@@ -125,17 +125,17 @@ define Build/Compile
        $(BUILD_BATTOOL)
 endef
 
-define Package/batmand-adv-userspace/install
+define Package/batman-adv-userspace/install
        $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/config $(1)/etc/init.d
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/batmand-adv $(1)/usr/sbin/
-       $(INSTALL_BIN) ./files/etc/init.d/batmand-adv-userspace $(1)/etc/init.d
-       $(INSTALL_DATA) ./files/etc/config/batmand-adv-userspace $(1)/etc/config
+       $(INSTALL_BIN) ./files/etc/init.d/batman-adv-userspace $(1)/etc/init.d
+       $(INSTALL_DATA) ./files/etc/config/batman-adv-userspace $(1)/etc/config
 endef
 
-define Package/batmand-adv-kernelland/install
+define Package/batman-adv-kernelland/install
        $(INSTALL_DIR) $(1)/etc/config $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/etc/init.d/batmand-adv-kernelland $(1)/etc/init.d
-       $(INSTALL_DATA) ./files/etc/config/batmand-adv-kernelland $(1)/etc/config
+       $(INSTALL_BIN) ./files/etc/init.d/batman-adv-kernelland $(1)/etc/init.d
+       $(INSTALL_DATA) ./files/etc/config/batman-adv-kernelland $(1)/etc/config
 endef
 
 define Package/battool/install
@@ -143,6 +143,6 @@ define Package/battool/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/battool $(1)/usr/sbin/
 endef
 
-$(eval $(call BuildPackage,batmand-adv-userspace))
+$(eval $(call BuildPackage,batman-adv-userspace))
 $(eval $(call BuildPackage,battool))
 $(eval $(call KernelPackage,batman-adv-kernelland))
diff --git a/net/batman-advanced/files/etc/config/batman-adv-kernelland b/net/batman-advanced/files/etc/config/batman-adv-kernelland
new file mode 100644 (file)
index 0000000..2106236
--- /dev/null
@@ -0,0 +1,4 @@
+config batman-adv-kernelland general
+       option interface                ath0
+       option originator_interval
+       option log_level        
diff --git a/net/batman-advanced/files/etc/config/batman-adv-userspace b/net/batman-advanced/files/etc/config/batman-adv-userspace
new file mode 100644 (file)
index 0000000..33dd034
--- /dev/null
@@ -0,0 +1,4 @@
+config batman-adv-userspace general
+       option interface                ath0
+       option originator_interval
+       option visualisation_srv        
diff --git a/net/batman-advanced/files/etc/config/batmand-adv-kernelland b/net/batman-advanced/files/etc/config/batmand-adv-kernelland
deleted file mode 100644 (file)
index 4ba0710..0000000
+++ /dev/null
@@ -1,4 +0,0 @@
-config batmand-adv-kernelland general
-       option interface                ath0
-       option originator_interval
-       option log_level        
diff --git a/net/batman-advanced/files/etc/config/batmand-adv-userspace b/net/batman-advanced/files/etc/config/batmand-adv-userspace
deleted file mode 100644 (file)
index b077b77..0000000
+++ /dev/null
@@ -1,4 +0,0 @@
-config batmand-adv-userspace general
-       option interface                ath0
-       option originator_interval
-       option visualisation_srv        
diff --git a/net/batman-advanced/files/etc/init.d/batman-adv-kernelland b/net/batman-advanced/files/etc/init.d/batman-adv-kernelland
new file mode 100644 (file)
index 0000000..649929a
--- /dev/null
@@ -0,0 +1,37 @@
+#!/bin/sh /etc/rc.common
+START=90
+. /lib/config/uci.sh
+uci_load batman-adv-kernelland
+start () {
+       interfaces=$(uci get batman-adv-kernalland.general.interface)
+       if [ "$interfaces" = "" ]; then
+               echo $1 Error, you must specify at least a network interface
+               exit
+       fi
+       
+       for interface in interfaces
+          do
+             echo $interface > /proc/net/batman-adv/interfaces
+          done
+          
+       originator_interval=$(uci get batman-adv-kernalland.general.originator_interval)
+       log_level=$(uci get batman-adv-kernalland.general.log_level)
+
+       if [ $originator_interval ]; then
+               echo $originator_interval > /proc/net/batman-adv/originator_interval
+       fi
+       
+       if [ $log_level ]; then
+               echo $log_level > /proc/net/batman-adv/log_level
+       fi
+}
+
+restart () {
+       $0 stop
+       sleep 3
+       $0 start
+}
+        
+stop () {
+       echo "" > /proc/net/batman-adv/interfaces
+}
diff --git a/net/batman-advanced/files/etc/init.d/batman-adv-userspace b/net/batman-advanced/files/etc/init.d/batman-adv-userspace
new file mode 100644 (file)
index 0000000..f634977
--- /dev/null
@@ -0,0 +1,35 @@
+#!/bin/sh /etc/rc.common
+START=90
+. /lib/config/uci.sh
+uci_load batman-adv-userspace
+start () {
+       interface=$(uci get batman-adv-userspace.general.interface)
+       if [ "$interface" = "" ]; then
+               echo $1 Error, you must specify at least a network interface
+               exit
+       fi
+       originator_interval=$(uci get batman-adv-userspace.general.originator_interval)
+       visualisation_srv=$(uci get batman-adv-userspace.general.visualisation_srv)
+       batman_args=""
+
+       if [ $originator_interval ]; then
+               batman_args=${batman_args}'-o '$originator_interval' '
+       fi
+
+       if [ $visualisation_srv ]; then
+               batman_args=${batman_args}'-s '$visualisation_srv' '
+       fi
+
+       batman_args=${batman_args}$interface
+       batmand-adv $batman_args >/dev/null 2>&1
+}
+
+restart () {
+       $0 stop
+       sleep 3
+       $0 start
+}
+        
+stop () {
+       killall batmand-adv
+}
diff --git a/net/batman-advanced/files/etc/init.d/batmand-adv-kernelland b/net/batman-advanced/files/etc/init.d/batmand-adv-kernelland
deleted file mode 100644 (file)
index b553841..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-#!/bin/sh /etc/rc.common
-START=90
-. /lib/config/uci.sh
-uci_load batmand-adv-kernelland
-start () {
-       interfaces=$(uci get batmand-adv-kernalland.general.interface)
-       if [ "$interface" = "" ]; then
-               echo $1 Error, you must specify at least a network interface
-               exit
-       fi
-       
-       for interface in interfaces
-          do
-             echo $interface > /proc/net/batman-adv/interfaces
-          done
-          
-       originator_interval=$(uci get batmand-adv-kernalland.general.originator_interval)
-       log_level=$(uci get batmand-adv-kernalland.general.log_level)
-
-       if [ $originator_interval ]; then
-               echo $originator_interval > /proc/net/batman-adv/originator_interval
-       fi
-       
-       if [ $log_level ]; then
-               echo $log_level > /proc/net/batman-adv/log_level
-       fi
-}
-
-restart () {
-       $0 stop
-       sleep 3
-       $0 start
-}
-        
-stop () {
-       echo "" > /proc/net/batman-adv/interfaces
-}
diff --git a/net/batman-advanced/files/etc/init.d/batmand-adv-userspace b/net/batman-advanced/files/etc/init.d/batmand-adv-userspace
deleted file mode 100644 (file)
index 9ea7e4f..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-#!/bin/sh /etc/rc.common
-START=90
-. /lib/config/uci.sh
-uci_load batmand-adv-userspace
-start () {
-       interface=$(uci get batmand-adv-userspace.general.interface)
-       if [ "$interface" = "" ]; then
-               echo $1 Error, you must specify at least a network interface
-               exit
-       fi
-       originator_interval=$(uci get batmand-adv-userspace.general.originator_interval)
-       visualisation_srv=$(uci get batmand-adv-space.general.visualisation_srv)
-       batman_args=""
-
-       if [ $originator_interval ]; then
-               batman_args=${batman_args}'-o '$originator_interval' '
-       fi
-
-       if [ $visualisation_srv ]; then
-               batman_args=${batman_args}'-s '$visualisation_srv' '
-       fi
-
-       batman_args=${batman_args}$interface
-       batmand-adv $batman_args >/dev/null 2>&1
-}
-
-restart () {
-       $0 stop
-       sleep 3
-       $0 start
-}
-        
-stop () {
-       killall batmand-adv
-}