[packages] gst-ffmpeg: force use of embedded FFmpeg headers
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 13 Oct 2011 13:17:25 +0000 (13:17 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 13 Oct 2011 13:17:25 +0000 (13:17 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@28440 3c298f89-4303-0410-b956-a3cf2f4a3e73

multimedia/gst-ffmpeg/Makefile

index 663244f..3d6841a 100644 (file)
@@ -134,7 +134,7 @@ GST_VERSION:=0.10
 
 CONFIGURE_ARGS += \
        --with-ffmpeg-extra-configure="--target-os=linux \
-                --disable-bsfs \
+               --disable-bsfs \
                --disable-devices \
                --disable-encoders \
                $(FFMPEG_CONFIGURE_ENCODERS) \
@@ -149,6 +149,10 @@ CONFIGURE_ARGS += \
                --disable-protocols \
                $(FFMPEG_CONFIGURE_PROTOCOLS)"
 
+# XXX: trick to force use of embedded FFmpeg headers
+TARGET_CFLAGS += $(TARGET_CPPFLAGS)
+TARGET_CPPFLAGS :=
+
 TARGET_LDFLAGS += $(FPIC)
 
 define Build/Prepare