bluez-utils: Fix ability to automatically ifup the transitory ppp connection for...
authorrwhitby <rwhitby@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 13 Dec 2008 13:25:31 +0000 (13:25 +0000)
committerrwhitby <rwhitby@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 13 Dec 2008 13:25:31 +0000 (13:25 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@13620 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/bluez-utils/Makefile
utils/bluez-utils/files/bluetooth.conf
utils/bluez-utils/files/bluez-utils.init

index 3c002dc..f2d999c 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bluez-utils
 PKG_VERSION:=3.36
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://bluez.sourceforge.net/download
index 54dcec0..dad576e 100644 (file)
@@ -10,7 +10,9 @@ config dund
        option listen   true
        option persist  true
        option msdun    true
-#      option pppdopts "ktune proxyarp 192.168.1.1:192.168.1.2 ms-dns 192.168.1.1"
+       option interface dund
+       option unit     1
+       option pppdopts "ktune proxyarp 192.168.1.1:192.168.1.2 ms-dns 192.168.1.1"
        option enabled  0
 
 config pand
index afd2294..13dadee 100644 (file)
@@ -63,7 +63,7 @@ dund_config() {
        append_string "$cfg" pppdopts ""
        config_get ifn "$cfg" interface
        if [ -n "$ifn" ]; then
-               config_get unit "$ifn" unit
+               config_get unit "$cfg" unit
                [ -z "$unit" ] || append args "unit $unit ipparam $ifn linkname $ifn"
        fi