[packages] lzo: update to version 2.06
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 16 Jul 2012 21:52:09 +0000 (21:52 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 16 Jul 2012 21:52:09 +0000 (21:52 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@32755 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/lzo/Makefile

index 1cb0397..87e858e 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,15 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lzo
-PKG_VERSION:=2.05
+PKG_VERSION:=2.06
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.oberhumer.com/opensource/lzo/download/
-PKG_MD5SUM:=c67cda5fa191bab761c7cb06fe091e36
+PKG_MD5SUM:=95380bd4081f85ef08c5209f4107e9f8
 
 PKG_FIXUP:=autoreconf
-
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
@@ -29,8 +28,8 @@ define Package/liblzo
 endef
 
 define Package/liblzo/description
-LZO is a data compression library which is suitable for data de-/compression in
-real-time. This means it favours speed over compression ratio.
+ LZO is a data compression library which is suitable for data de-/compression
+ in real-time. This means it favours speed over compression ratio.
 endef
 
 define Build/Configure
@@ -41,14 +40,11 @@ define Build/Configure
 endef
 
 TARGET_CFLAGS += $(FPIC)
-
 MAKE_FLAGS += CFLAGS_O="$(TARGET_CFLAGS)"
 
 define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/include/lzo $(1)/usr/include/
-
-       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblzo2.{a,so*} $(1)/usr/lib/
 endef