[packages] transmission: update to 2.12, remove obsolete options
authorobsy <obsy@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 14 Nov 2010 18:42:54 +0000 (18:42 +0000)
committerobsy <obsy@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 14 Nov 2010 18:42:54 +0000 (18:42 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@23992 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/transmission/Makefile
net/transmission/files/transmission.config
net/transmission/files/transmission.init

index 0078052..4c91d1e 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=transmission
-PKG_VERSION:=2.11
+PKG_VERSION:=2.12
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://mirrors.m0k.org/transmission/files
-PKG_MD5SUM:=ef2b40ddc2c17a57c47bfe15b1f23cc4
+PKG_MD5SUM:=f3d34fdbbf3ae25635f9e7bf7e662cd9
 
 PKG_FIXUP:=libtool
 PKG_INSTALL:=1
index cd3450d..dbc5407 100644 (file)
@@ -11,6 +11,7 @@ config transmission
        option bind_address_ipv4 '0.0.0.0'
        option bind_address_ipv6 '::'
        option blocklist_enabled false
+       option blocklist_url ''
        option cache_size_mb 2
        option dht_enabled true
        option download_dir '/tmp/transmission/done'
@@ -33,13 +34,6 @@ config transmission
        option pex_enabled true
        option port_forwarding_enabled true
        option preallocation 1
-       option proxy ''
-       option proxy_auth_enabled false
-       option proxy_auth_password ''
-       option proxy_auth_username ''
-       option proxy_enabled false
-       option proxy_port 80
-       option proxy_type 0
        option ratio_limit 2.0000
        option ratio_limit_enabled false
        option rename_partial_files true
index be816c4..80fdf85 100644 (file)
@@ -58,16 +58,15 @@ start_service() {
                open_file_limit peer_limit_global peer_limit_per_torrent peer_port \
                peer_port_random_high peer_port_random_low peer_port_random_on_start \
                peer_socket_tos pex_enabled port_forwarding_enabled preallocation \
-               proxy_auth_enabled proxy_enabled proxy_port proxy_type ratio_limit \
-               ratio_limit_enabled rename_partial_files rpc_authentication_required \
+               ratio_limit ratio_limit_enabled rename_partial_files rpc_authentication_required \
                rpc_enabled rpc_port rpc_whitelist_enabled script_torrent_done_enabled \
                speed_limit_down speed_limit_down_enabled speed_limit_up \
                speed_limit_up_enabled start_added_torrents trash_original_torrent_files \
                umask upload_slots_per_torrent watch_dir_enabled
 
        append_params_quotes "$s" \
-               bind_address_ipv4 bind_address_ipv6 download_dir incomplete_dir proxy \
-               proxy_auth_password proxy_auth_username rpc_bind_address rpc_password \
+               blocklist_url bind_address_ipv4 bind_address_ipv6 download_dir incomplete_dir \
+               rpc_bind_address rpc_password \
                rpc_username rpc_whitelist script_torrent_done_filename watch_dir
 
        echo "\""invalid-key"\": false" >> $config_dir/settings.json