[packages] aiccu: Add 'restart' option to force restart of daemon instead of HUP...
authoracinonyx <acinonyx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 3 Nov 2011 16:05:42 +0000 (16:05 +0000)
committeracinonyx <acinonyx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 3 Nov 2011 16:05:42 +0000 (16:05 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@28727 3c298f89-4303-0410-b956-a3cf2f4a3e73

ipv6/aiccu/Makefile
ipv6/aiccu/files/aiccu.hotplug
ipv6/aiccu/files/aiccu.init

index 496fce4..b2c4f22 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=aiccu
 PKG_VERSION:=20070115
-PKG_RELEASE:=6
+PKG_RELEASE:=7
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.sixxs.net/archive/sixxs/aiccu/unix
index b886976..5830415 100644 (file)
@@ -1,2 +1,2 @@
 #!/bin/sh
-[ "$ACTION" = "ifup" -a "$INTERFACE" = "wan" ] && /etc/init.d/aiccu enabled && /etc/init.d/aiccu start
+[ "$ACTION" = "ifup" -a "$INTERFACE" = "wan" ] && /etc/init.d/aiccu enabled && /etc/init.d/aiccu restart
index bc5ef75..9261db8 100644 (file)
@@ -57,7 +57,8 @@ stop_instance() {
 
 restart_instance() {
        local cfg="$1"
-       stop_instance "$cfg"
+       config_get_bool restart "$cfg" restart 0
+       [ "$restart" -eq 1 ] && stop_instance "$cfg"
        start_instance "$cfg"
 }