[package] openl2tp: fix library path
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 20 Apr 2012 13:26:14 +0000 (13:26 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 20 Apr 2012 13:26:14 +0000 (13:26 +0000)
When host is x86_64 other than Debian, the Makefile of openl2tp uses /usr/lib64
as SYS_LIBDIR instead of /usr/lib.
Aparently setting CROSS_COMPILE is the way the authors intended to handle this
situation correctly.

Signed-off-by: Daniel Golle <dgolle@allnet.de>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@31366 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/openl2tp/Makefile

index a263e1a..83c14b5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2011 OpenWrt.org
+# Copyright (C) 2009-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=openl2tp
 PKG_VERSION:=1.8
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/openl2tp
@@ -79,6 +79,7 @@ MAKE_FLAGS+= \
        CFLAGS.optimize="$(TARGET_CFLAGS)" \
        CPPFLAGS-y="-I$(STAGING_DIR)/usr/include" \
        L2TP_FEATURE_LOCAL_CONF_FILE=y \
+       CROSS_COMPILE="$(TARGET_CROSS)" \
 
 ifeq ($(BUILD_VARIANT),full)