[packages_10.03.2] totd: merge r27610, r28928, r29199
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 03:28:36 +0000 (03:28 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 5 Feb 2012 03:28:36 +0000 (03:28 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/packages_10.03.2@30177 3c298f89-4303-0410-b956-a3cf2f4a3e73

ipv6/totd/Makefile
ipv6/totd/files/totd.init
ipv6/totd/patches/001-no_warning_as_errors.patch

index 0d2cf9f..e67bc57 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,10 +9,10 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=totd
 PKG_VERSION:=1.5.1
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=ftp://ftp.pasta.cs.uit.no/pub/totd/
+PKG_SOURCE_URL:=http://www.dillema.net/software/totd
 PKG_MD5SUM:=7edaedae9f6aca5912dd6c123582cf08
 
 include $(INCLUDE_DIR)/package.mk
@@ -22,7 +22,7 @@ define Package/totd
   CATEGORY:=IPv6
   DEPENDS:=+kmod-ipv6
   TITLE:=Small DNS proxy that supports IPv6/IPv4 record translation
-  URL:=http://pasta.cs.uit.no/software/totd.html
+  URL:=http://www.dillema.net/software/totd.html
 endef
 
 define Package/totd/description
@@ -53,4 +53,8 @@ define Package/totd/install
        $(INSTALL_BIN) ./files/totd.init $(1)/etc/init.d/totd
 endef
 
+define Package/totd/conffiles
+/etc/totd.conf
+endef
+
 $(eval $(call BuildPackage,totd))
index c12cc41..9c2dd74 100644 (file)
@@ -1,23 +1,14 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 
 START=60
-BIN=totd
-RUN_D=/var/run
-PID_F=$RUN_D/$BIN.pid
 
+SERVICE_USE_PID=1
 
 start() {
-       mkdir -p $RUN_D
-       $BIN -c /etc/totd.conf
+       service_start /usr/sbin/totd -c /etc/totd.conf
 }
 
 stop() {
-       [ -f $PID_F ] && kill $(cat $PID_F)
-}
-
-restart() {
-       stop
-       sleep 1
-       start
+       service_stop /usr/sbin/totd
 }
index 88fc359..3f8f3b4 100644 (file)
@@ -1,7 +1,6 @@
-diff -urN totd-1.5.1/Makefile.in totd-1.5.1.new/Makefile.in
---- totd-1.5.1/Makefile.in     2005-01-31 12:55:14.000000000 +0100
-+++ totd-1.5.1.new/Makefile.in 2007-02-26 12:12:05.000000000 +0100
-@@ -19,7 +19,7 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -19,7 +19,7 @@ TOT_CONFIG_FILE=@sysconfdir@/totd.conf
  
  INSTALL = /usr/bin/install