open-plc-utils: pass our CFLAGS and LDFLAGS for linking
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Mar 2014 00:57:24 +0000 (00:57 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Mar 2014 00:57:24 +0000 (00:57 +0000)
Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@39819 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/open-plc-utils/Makefile

index 39ea4c1..2137c5f 100644 (file)
@@ -73,6 +73,7 @@ $(foreach a,$(OPEN_PLC_UTILS_APPS),$(eval $(call GenPlugin,$(a))))
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                EXTRA_CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
+               LDFLAGS="$(TARGET_CFLAGS) $(TARGET_LDFLAGS)" \
                CROSS="$(TARGET_CROSS)" \
                ROOTFS="$(PKG_INSTALL_DIR)" \
                OWNER="$(shell id -u $(shell whoami))" \