mysql: fix a compile error on some host systems.
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 9 Apr 2011 12:58:10 +0000 (12:58 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 9 Apr 2011 12:58:10 +0000 (12:58 +0000)
conf_to_src.c uses C++ functions so we should use g++ for compiling.
The CFLAGS, CPPFLAGS and LDFLAGS for host build should be used and not the for target builds.

This closes #8342

git-svn-id: svn://svn.openwrt.org/openwrt/packages@26540 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/mysql/Makefile

index dba90cb..3dcae75 100644 (file)
@@ -120,10 +120,10 @@ define Build/Compile
                DESTDIR="$(PKG_INSTALL_DIR)" \
                install
        $(MAKE) $(PKG_JOBS) -C "$(PKG_BUILD_DIR)/libmysql" \
-               CC="$(HOSTCC)" \
-               LINK="$(HOSTCC) -o conf_to_src -lc" \
-               CFLAGS="" \
-               CPPFLAGS="" \
+               CC="g++" \
+               CFLAGS="$(HOST_CFLAGS)" \
+               CPPFLAGS="$(HOST_CFLAGS)" \
+               LDFLAGS="$(HOST_LDFLAGS)" \
                conf_to_src
        $(MAKE) $(PKG_JOBS) -C "$(PKG_BUILD_DIR)" \
                SUBDIRS="libmysql" \