packages/scmpc: use new service functions
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 12 Nov 2011 01:30:27 +0000 (01:30 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 12 Nov 2011 01:30:27 +0000 (01:30 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@28968 3c298f89-4303-0410-b956-a3cf2f4a3e73

sound/scmpc/Makefile
sound/scmpc/files/scmpc.init

index de36e41..4013085 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=scmpc
 PKG_VERSION:=0.2.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://download.berlios.de/scmpc
index 5b12d35..5327b6b 100644 (file)
@@ -1,12 +1,15 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
+
 START=94
 
+SERVICE_USE_PID=1
+
 start() {
-       mkdir -p /var/lib/scmpc
-       /usr/bin/scmpc
+       mkdir -m 0755 -p /var/lib/scmpc
+       service_start /usr/bin/scmpc
 }
 
 stop() {
-       killall scmpc
+       service_stop /usr/bin/scmpc
 }