packages/xinetd: use new service functions
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 9 Nov 2011 23:29:31 +0000 (23:29 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 9 Nov 2011 23:29:31 +0000 (23:29 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@28908 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/xinetd/Makefile
net/xinetd/files/xinetd.init

index 176cfa5..52b1dea 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xinetd
 PKG_VERSION:=2.3.14
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.xinetd.org/
index c11994b..1437f58 100644 (file)
@@ -1,18 +1,15 @@
 #!/bin/sh /etc/rc.common
 # Copyright (C) 2006-2011 OpenWrt.org
+
 START=50
 
-DEFAULT=/etc/default/xinetd
-RUN_D=/var/run
-PID_F=$RUN_D/xinetd.pid
+SERVICE_USE_PID=1
 
 start() {
-       [ -f $DEFAULT ] && . $DEFAULT
-       [ -d $RUN_D ] || mkdir -p $RUN_D
-       xinetd -pidfile $PID_F $OPTIONS
+       service_start /usr/sbin/xinetd -pidfile /var/run/xinetd.pid
 }
 
 stop() {
-       [ -f $PID_F ] && kill $(cat $PID_F)
+       service_stop /usr/sbin/xinetd
 }