[packages] libconfig: install pkgconfig data in staging dir
authoracinonyx <acinonyx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 16 Apr 2012 11:44:16 +0000 (11:44 +0000)
committeracinonyx <acinonyx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 16 Apr 2012 11:44:16 +0000 (11:44 +0000)
And while at it, include all symlinks for the library file in the package.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Signed-off-by: Vasilis Tsiligiannis <b_tsiligiannis@silverton.gr>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@31304 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/libconfig/Makefile

index b5f9885..49dcf90 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libconfig
 PKG_VERSION:=1.4.8
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.hyperrealm.com/libconfig
@@ -49,11 +49,13 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/include/libconfig.h $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libconfig.{a,so*} $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libconfig.pc $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/libconfig/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libconfig.so.* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libconfig.so* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libconfig))