bonnie++: pass TARGET_CXXFLAGS correctly
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Mar 2014 00:56:32 +0000 (00:56 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Mar 2014 00:56:32 +0000 (00:56 +0000)
bonnie++ was not compiled using the TARGET_CXXFLAGS we passed, which will result
in build failures on e.g: ARM VFP toolchains, fix that.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@39798 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/bonnie++/Makefile

index bb77113..55fe123 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bonnie++
 PKG_VERSION:=1.96
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://www.coker.com.au/bonnie++/experimental/
@@ -36,6 +36,7 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                TARGET_CXX="$(TARGET_CXX)" \
                TARGET_LINK="$(TARGET_CXX)" \
+               MORECFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CXXFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all
 endef