gupnp: add package
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 5 Dec 2012 17:31:23 +0000 (17:31 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 5 Dec 2012 17:31:23 +0000 (17:31 +0000)
Signed-off-by: Andy Leiserson <andy@leiserson.org>
Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@34517 3c298f89-4303-0410-b956-a3cf2f4a3e73

libs/gupnp/Makefile [new file with mode: 0644]

diff --git a/libs/gupnp/Makefile b/libs/gupnp/Makefile
new file mode 100644 (file)
index 0000000..9b75144
--- /dev/null
@@ -0,0 +1,70 @@
+#
+# Copyright (C) 2006-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=gupnp
+PKG_VERSION:=0.18.3
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=http://ftp.gnome.org/pub/GNOME/sources/gupnp/0.18/
+PKG_MD5SUM:=1086654db47def9fbe9fc54c1228d663
+
+PKG_BUILD_DEPENDS:=libgnutls
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
+
+TARGET_LDFLAGS+=\
+        -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
+
+define Package/libgupnp
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=Library for implementing both UPnP clients and services in C
+  URL:=http://www.gupnp.org/
+  DEPENDS:=+libgssdp +libuuid
+endef
+
+define Package/libgupnp/description
+GUPnP is a library for implementing both UPnP clients and services in C, using
+GObject and LibSoup. It allows for fully asynchronous use without using threads
+and so cleanly integrates naturally into main-loop based applications, and
+supports all of the UPnP features.
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/{lib/pkgconfig,include/gupnp-1.0/libgupnp}
+
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libgupnp-1.0.{so*,la,a} \
+               $(1)/usr/lib/
+
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc \
+               $(1)/usr/lib/pkgconfig/
+
+       $(INSTALL_DATA) \
+               $(PKG_INSTALL_DIR)/usr/include/gupnp-1.0/libgupnp/*.h \
+               $(1)/usr/include/gupnp-1.0/libgupnp/
+endef
+
+define Package/libgupnp/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libgupnp-1.0.so* \
+               $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libgupnp))