[packages] collectd: fix another build failure on avr32
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 16 Jul 2010 13:33:09 +0000 (13:33 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 16 Jul 2010 13:33:09 +0000 (13:33 +0000)
the ted plugin fails on avr32 with the following error:

cc1: warnings being treated as errors
ted.c: In function 'ted_read_value':
ted.c:153: warning: format '%zi' expects type 'signed size_t', but argument 3 has type 'ssize_t'

git-svn-id: svn://svn.openwrt.org/openwrt/packages@22234 3c298f89-4303-0410-b956-a3cf2f4a3e73

utils/collectd/Makefile

index 763a600..6119572 100644 (file)
@@ -276,7 +276,7 @@ $(eval $(call BuildPlugin,syslog,syslog output,syslog,))
 $(eval $(call BuildPlugin,tail,tail input,tail,))
 $(eval $(call BuildPlugin,table,table-like structured file input,table,))
 $(eval $(call BuildPlugin,teamspeak2,TeamSpeak2 input,teamspeak2,))
-$(eval $(call BuildPlugin,ted,The Energy Detective input,ted,))
+$(eval $(call BuildPlugin,ted,The Energy Detective input,ted,@((!TARGET_avr32)||BROKEN))) # fails on avr32 because of warnings treated as errors
 $(eval $(call BuildPlugin,tcpconns,TCP connection tracking input,tcpconns,))
 $(eval $(call BuildPlugin,thermal,system temperatures input,thermal,))
 $(eval $(call BuildPlugin,unixsock,unix socket output,unixsock,))