[packages] cups: change user:group from root:root to nobody:nogroup (closes: #7180...
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 18 Apr 2010 12:37:48 +0000 (12:37 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 18 Apr 2010 12:37:48 +0000 (12:37 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@20981 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/cups/Makefile
net/cups/files/etc/cups/cupsd.conf

index 1a2b969..f453fa3 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cups
 PKG_VERSION:=1.4.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-source.tar.bz2
 PKG_SOURCE_URL:= \
@@ -46,14 +46,17 @@ endef
 
 define Build/Configure
        $(call Build/Configure/Default, \
-               --with-cups-user=root \
-               --with-cups-group=root \
+               --with-cups-user="nobody" \
+               --with-cups-group="nogroup" \
                --without-perl \
                --without-python \
                --without-php \
                --enable-shared \
                --enable-image \
                --disable-dbus \
+               --disable-dnssd \
+               --disable-launchd \
+               --disable-ldap \
                --disable-pam \
                --disable-slp \
                --disable-gnutls \
@@ -61,7 +64,7 @@ define Build/Configure
                --disable-cdsassl \
                --disable-ssl \
                --disable-gssapi \
-               --disable-slp, \
+               --disable-tiff, \
                UNAME="Linux" \
                LIBS="$(TARGET_LDFLAGS) -lz -lpng -ljpeg" \
        )
index 0bef5d9..79ad944 100644 (file)
@@ -23,8 +23,8 @@ MaxPrinterHistory 10
 #PrintcapFormat BSD
 RequestRoot /var/cups
 #RemoteRoot remroot
-User root
-Group root
+User nobody
+Group nogroup
 RIPCache 512k
 TempDir /var/cups
 Port 631